rtl-sdr with bias T

Cinaed Simson cinaed.simson at gmail.com
Thu Feb 8 09:36:26 UTC 2018


On 02/07/2018 12:25 AM, Bill Gaylord wrote:
> This has to do with the ordering of the set bandwidth function I believe. (From my experience with it.) because you can set the bandwidth before the freq is set the chip thinks you are trying to do stuff before the PLL is locked. Which is actually true. But this has no real effect on the usage of device from what I can see. 

Thanks for the reply.

In my case, when I use version v0.5git, I can only located 2 independent
GSM channels.

But when I use v0.5.3, I can locate 13 independent GSM channels.

I'm using a R820T from noelec

  https://www.nooelec.com/store/nesdr-smart-sdr.html

I'll make sure I can reproduce the problem on Friday.


-- Cinaed


> 
> 
>> On Feb 6, 2018, at 10:53 PM, Cinaed Simson <cinaed.simson at gmail.com> wrote:
>>
>>
>> Hi - there appears to be problem with rtl-sdr with bias T and the
>> RTL2832U OEM Rafael Micro R820T tuner.
>>
>> I get PLL errors when I try to calibrate it using kal - or when I use
>> rtl_test.
>>
>> Using device 0: Generic RTL2832U OEM
>> Found Rafael Micro R820T tuner
>> Exact sample rate is: 270833.002142 Hz
>> [R82XX] PLL not locked!
>> Setting gain: 33.8 dB
>>
>> And I get the same error PLL when I run rtl_test.
>>
>> If I back out of the latest git version to v0.5.3 it works correctly - I
>> can calibrate the dongle using kal and run rtl_test without any PLL errors.
>>
>> This is a known problem?
>>
>> -- Cinaed
>>
>>
> 



More information about the osmocom-sdr mailing list