Is My RTL2838U + R820T Tuner working?

Curt Carpenter 1cjcarpenter at att.net
Tue Aug 20 02:48:21 UTC 2013


Thanks for the link Skip.  I used the first example in the guide (with 
freq changed to a known local FM station) as

rtl_fm -W -f 90.1M | play -r 32k -t raw -e signed-integer -b 16 -c 1 -V1 -

but all I am able to hear is noise.  So I'm still stuck wondering if my 
dongle is working or not since I can't get any signals at all -- only noise.

I get two messages that look like the may indicate a problem:

"[R820T] PLL not locked for 3926090 Hz"

and

"WARNING:  Failed to set center frequency."

Any idea what these mean?

On 8/19/2013 6:03 PM, Skip Tavakkolian wrote:
> For a quick sanity check I use rtl_fm to tune into a local FM station. 
> Here is a good guide for rtl_fm:
>
> http://kmkeen.com/rtl-demod-guide/index.html
>
>
> On Aug 19, 2013, at 2:02 PM, Curt Carpenter <1cjcarpenter at att.net 
> <mailto:1cjcarpenter at att.net>> wrote:
>
>> Hello!
>>
>> I received my USB-DVB-T+DAB+FM dongle last week, and have been trying 
>> to find a signal with it since, but with no luck.  Can anyone tell me 
>> how to tell if it is working at all?
>>
>> I'm using the Windows version of Osmocom under WinXP.
>>
>> Using rtl_eeprom, I get the following display:
>> --------------------------
>>
>> Vendor ID                               0x0bda
>> Product ID                              0x2838
>> Manufacturer                          Realtek
>> Product                                   RTL2838UHIDIR
>> Serial Number                        00000000001
>> Serial Number Enabled        Yes
>> IR Endpoint Enabled             Yes
>> Remote Wakeup Enabled     No
>>
>> -----------------------
>>
>> When I run
>>
>> rtl_test -s 1.6e6
>>
>> I get the following response:
>>
>> -----------------------
>>
>> Found 1 device(s)
>>   0:  ezcap USB 2.0 DVB-T/DAB/FM dongle
>> Using device 0:  ezcap USB 2.0 DVB-T/DAB/FM dongle
>> Supported gain values(29):  0.0 0.9 .... 49.6
>> Info:  This tool will continuously read from the device, and report 
>> if samples get lost.
>> If you observer no further output, everything is fine.
>>
>> Reading samples in async mode...
>>
>> --------------------------
>>
>> If at that point after a while I press Control C, I get
>>
>> ---------------------------
>>
>> Signal caught, exiting!
>>
>> ---------------------------
>>
>> But then my command prompt window hangs up and will do nothing until 
>> I close it all together.
>>
>> Does it appear that my dongle is working?  Where do I find out how to 
>> use the different gains that are listed by rtl_test?  Could my 
>> difficulties have anything to do with the fact that my dongle is IR 
>> Endpoint enabled?
>>
>> I am brand new to this, and haven't had much luck so far, although I 
>> think I've gotten further with Osmocom and Windows than with anything 
>> else I've tried.  Any help/advice/links to more information will be 
>> much appreciated.  Sorry for the long post -- I was trying to provide 
>> as much information as I could.
>>
>>
>> Thanks
>> Curt Carpenter
>>
>>
>>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/osmocom-sdr/attachments/20130819/39364bbd/attachment.html>


More information about the osmocom-sdr mailing list