Is My RTL2838U + R820T Tuner working?

Curt Carpenter 1cjcarpenter at att.net
Mon Aug 19 21:02:25 UTC 2013


Hello!

I received my USB-DVB-T+DAB+FM dongle last week, and have been trying to 
find a signal with it since, but with no luck.  Can anyone tell me how 
to tell if it is working at all?

I'm using the Windows version of Osmocom under WinXP.

Using rtl_eeprom, I get the following display:
--------------------------

Vendor ID                               0x0bda
Product ID                              0x2838
Manufacturer                          Realtek
Product                                   RTL2838UHIDIR
Serial Number                        00000000001
Serial Number Enabled        Yes
IR Endpoint Enabled             Yes
Remote Wakeup Enabled     No

-----------------------

When I run

rtl_test -s 1.6e6

I get the following response:

-----------------------

Found 1 device(s)
    0:  ezcap USB 2.0 DVB-T/DAB/FM dongle
Using device 0:  ezcap USB 2.0 DVB-T/DAB/FM dongle
Supported gain values(29):  0.0 0.9 .... 49.6
Info:  This tool will continuously read from the device, and report if 
samples get lost.
If you observer no further output, everything is fine.

Reading samples in async mode...

--------------------------

If at that point after a while I press Control C, I get

---------------------------

Signal caught, exiting!

---------------------------

But then my command prompt window hangs up and will do nothing until I 
close it all together.

Does it appear that my dongle is working?  Where do I find out how to 
use the different gains that are listed by rtl_test?  Could my 
difficulties have anything to do with the fact that my dongle is IR 
Endpoint enabled?

I am brand new to this, and haven't had much luck so far, although I 
think I've gotten further with Osmocom and Windows than with anything 
else I've tried.  Any help/advice/links to more information will be much 
appreciated.  Sorry for the long post -- I was trying to provide as much 
information as I could.


Thanks
Curt Carpenter






More information about the osmocom-sdr mailing list