osmo-hlr.git branch neels/subscr_vty updated. 0.0.1-82-g49a1e52

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/osmocom-commitlog@lists.osmocom.org/.

gitosis at osmocom.org gitosis at osmocom.org
Fri Oct 6 02:32:34 UTC 2017


This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "UNNAMED PROJECT".

The branch, neels/subscr_vty has been updated
  discards  62db9cab5d2aef4be8684e574746182594fc90bd (commit)
  discards  93d11dd4c57be3a0a7cc18c337270648f93166ce (commit)
  discards  1097a649864ab8ebd4a4d2c52f7dd38219e9e943 (commit)
       via  49a1e52b521dd512be64a12421c4470404d7d6af (commit)
       via  95ed968bee34c19f65e3ef98647be8001f1749f7 (commit)
       via  6c724f9e6df914489cc9cd01ff5db5b21cc29c78 (commit)
       via  e35b4c943b8ea6f102c51da74d6f1835f0cb9055 (commit)
       via  7e8a572e5c78fee018fdcbce6ca9d4b6d6463af1 (commit)
       via  d6f580a0456a7b64f154ccdca28feab70227a13f (commit)
       via  a27f8af0485c95436d9d9423dd069989ff89e9d7 (commit)
       via  85a0e57bc3459234efd5acb8900ab52a997fa554 (commit)
       via  3ef07d2596b3c2eee8570d3ed779379c2b6330dd (commit)
       via  d4650f67a31b7919ee9f8297459e66eb09c3d46c (commit)

This update added new revisions after undoing existing revisions.  That is
to say, the old revision is not a strict subset of the new revision.  This
situation occurs when you --force push a change and generate a repository
containing something like this:

 * -- * -- B -- O -- O -- O (62db9cab5d2aef4be8684e574746182594fc90bd)
            \
             N -- N -- N (49a1e52b521dd512be64a12421c4470404d7d6af)

When this happens we assume that you've already had alert emails for all
of the O revisions, and so we here report only the revisions in the N
branch from the common base, B.

Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.

- Log -----------------------------------------------------------------
http://cgit.osmocom.org/osmo-hlr/commit/?id=49a1e52b521dd512be64a12421c4470404d7d6af

commit 49a1e52b521dd512be64a12421c4470404d7d6af
Author: Neels Hofmeyr <neels at hofmeyr.de>
Date:   Fri Oct 6 02:59:54 2017 +0200

    implement subscriber vty, tests

http://cgit.osmocom.org/osmo-hlr/commit/?id=95ed968bee34c19f65e3ef98647be8001f1749f7

commit 95ed968bee34c19f65e3ef98647be8001f1749f7
Author: Neels Hofmeyr <neels at hofmeyr.de>
Date:   Tue Oct 3 01:23:50 2017 +0200

    enhance subscr db API, tests
    
    Change-Id: I3803399bec4fb49ab7f37a01ed6378ace849e59a

http://cgit.osmocom.org/osmo-hlr/commit/?id=6c724f9e6df914489cc9cd01ff5db5b21cc29c78

commit 6c724f9e6df914489cc9cd01ff5db5b21cc29c78
Author: Neels Hofmeyr <neels at hofmeyr.de>
Date:   Fri Oct 6 04:26:21 2017 +0200

    db: use int64_t as subscriber id
    
    The SQLite db does not support uint64_t, and we are always binding the uint64_t
    id actually as signed int64. Hence be consistent and actually handle it as
    int64_t in the code as well.
    
    todo: what about sqn
    Change-Id: I83a47289a48ac37da0f712845d422e897a5e8171

http://cgit.osmocom.org/osmo-hlr/commit/?id=e35b4c943b8ea6f102c51da74d6f1835f0cb9055

commit e35b4c943b8ea6f102c51da74d6f1835f0cb9055
Author: Neels Hofmeyr <neels at hofmeyr.de>
Date:   Fri Oct 6 04:20:37 2017 +0200

    cosmetic: don't log about missing SQLite log cb
    
    SQLite3 seems to be commonly compiled without log callback support. It is then
    misleading to see a seeming error message about this on each osmo-hlr startup.
    
    Avoid the impression that we would miss out on error logging by simply ignoring
    any errors upon registering the log callback. We do receive logging on each DB
    error.
    
    Change-Id: I78d75dc351eb587b0a022f82f147e9a31c0324c5

http://cgit.osmocom.org/osmo-hlr/commit/?id=7e8a572e5c78fee018fdcbce6ca9d4b6d6463af1

commit 7e8a572e5c78fee018fdcbce6ca9d4b6d6463af1
Author: Neels Hofmeyr <neels at hofmeyr.de>
Date:   Fri Oct 6 04:10:06 2017 +0200

    refactor db_subscr_ps() to db_subscr_nam()
    
    Allow to set nam_ps and nam_cs from this same function, by adding the is_ps
    arg.
    
    Combine both NAM_PS stmts to DB_STMT_UPD_NAM_PS_BY_IMSI, add another such stmt
    for CS. Use named parameters instead of parameter indexes.
    
    Improve error return values as well as error logging to clearly indicate
    whether the operation could not find the requested IMSI, or other errors
    occured.
    
    Adjust the single caller.
    
    This prepares for upcoming VTY and possibly CTRL commands, and the error
    handling introduced here will be adopted by other functions in subsequent
    patches.
    
    Change-Id: I6e70e15228f5bb10bee6758ae5dc9687d65839bd

http://cgit.osmocom.org/osmo-hlr/commit/?id=d6f580a0456a7b64f154ccdca28feab70227a13f

commit d6f580a0456a7b64f154ccdca28feab70227a13f
Author: Neels Hofmeyr <neels at hofmeyr.de>
Date:   Fri Oct 6 03:50:30 2017 +0200

    less noise: simplify db_remove_reset()
    
    db_remove_reset() needs to be called after each stmt run, whether it succeeded
    or not.
    
    In case sqlite3_clear_bindings() would fail to unbind a stmt, we would anyway
    be beyond recovery. There seem to be no plausible situations where such failure
    would occur, unless there have been no bindings in the first place.
    
    In case there was an SQL stmt failure, sqlite3_reset() will re-barf the same
    error message, we will always have logged it earlier already in the proper
    context.
    
    We are never evaluating the return value, nor would we know how to recover from
    non-success.
    
    The conclusions:
    - db_remove_reset() does not need to log any errors.
    - db_remove_reset() does not need to return success.
    
    Change-Id: I21678463e59f607f5f5c5732963e274392f0fffd

http://cgit.osmocom.org/osmo-hlr/commit/?id=a27f8af0485c95436d9d9423dd069989ff89e9d7

commit a27f8af0485c95436d9d9423dd069989ff89e9d7
Author: Neels Hofmeyr <neels at hofmeyr.de>
Date:   Fri Oct 6 03:44:57 2017 +0200

    add db_bind_int*()
    
    Change-Id: I705a15eef242c98feb6e95a883916f6cf8173d70

http://cgit.osmocom.org/osmo-hlr/commit/?id=85a0e57bc3459234efd5acb8900ab52a997fa554

commit 85a0e57bc3459234efd5acb8900ab52a997fa554
Author: Neels Hofmeyr <neels at hofmeyr.de>
Date:   Fri Oct 6 03:40:52 2017 +0200

    cosmetic: refactor db_bind_imsi() as db_bind_text()
    
    There are more uses for a generalized db_bind_text(), and in an upcoming patch
    there will be similar functions like db_bind_int().
    
    Also, add argument param_name, optionally indicating a named SQL parameter to
    bind to, which will be used in subsequent patches. So far, all callers pass
    NULL to yield previous db_bind_imsi() behavior of binding to the first param.
    
    Change-Id: I87bc46a23a724677e8319d6a4b032976b7ba9394

http://cgit.osmocom.org/osmo-hlr/commit/?id=3ef07d2596b3c2eee8570d3ed779379c2b6330dd

commit 3ef07d2596b3c2eee8570d3ed779379c2b6330dd
Author: Neels Hofmeyr <neels at hofmeyr.de>
Date:   Fri Oct 6 03:20:14 2017 +0200

    cosmetic: rename db_subscr_get() to db_subscr_get_by_imsi()
    
    There will be more additions, _by_msisdn() and _by_id(), to serve the upcoming
    VTY commands, to allow flexibly selecting subscribers as in the old OsmoNITB.
    
    Change-Id: I32fa676ccc5c10eba834c4390c8a42476b9c1961

http://cgit.osmocom.org/osmo-hlr/commit/?id=d4650f67a31b7919ee9f8297459e66eb09c3d46c

commit d4650f67a31b7919ee9f8297459e66eb09c3d46c
Author: Neels Hofmeyr <neels at hofmeyr.de>
Date:   Fri Oct 6 03:09:34 2017 +0200

    cosmetic: prepend DB_STMT_ to enum stmt_idx entries
    
    There are upcoming additions, and some are too general without a proper common
    prefix in the identifiers.
    
    Change-Id: I51b677db31a1ebbbc45dc7925074de7493fbde1f

-----------------------------------------------------------------------

Summary of changes:
 src/ctrl.c           |   2 +-
 src/db.c             |  77 ++++--
 src/db.h             |  23 +-
 src/db_auc.c         |   6 +-
 src/db_hlr.c         | 288 ++++++++++++++------
 src/hlr.c            |   2 +-
 tests/db/Makefile.am |  20 +-
 tests/db/db_test.c   | 308 +++++++++++++++++++++-
 tests/db/db_test.err | 725 +++++++++++++++++++++++++++++++++++++++++++++++++++
 tests/db/db_test.ok  |   2 +
 tests/testsuite.at   |   2 +-
 11 files changed, 1323 insertions(+), 132 deletions(-)
 create mode 100644 tests/db/db_test.err
 create mode 100644 tests/db/db_test.ok


hooks/post-receive
-- 
UNNAMED PROJECT



More information about the osmocom-commitlog mailing list