osmo-gsm-manuals in project repos: I see no .pdf

Oliver Smith osmith at sysmocom.de
Wed Nov 28 09:12:50 UTC 2018


Oh, you were probably looking for them in the root directory, right?
They get placed in doc/manuals/:

$ cd osmo-bsc
$ ./configure --enable-manuals
$ make
$ find -name '*.pdf'
./doc/manuals/osmobsc-vty-reference.pdf
./doc/manuals/osmux-reference.pdf
./doc/manuals/osmobsc-usermanual.pdf
./doc/manuals/aoip-mgw-options.pdf

$ cd ../osmo-msc
$ ./configure --enable-manuals
$ make
$ find -name '*.pdf'
./doc/manuals/osmomsc-usermanual.pdf
./doc/manuals/osmomsc-vty-reference.pdf

Sorry for the confusion and thanks for merging the patches. I see that
you have even adjusted the commit message everywhere.

Oliver


On 11/28/18 10:05 AM, Oliver Smith wrote:
> Worked for me™
> 
> I'll look into it right away.
> 
> 
> On 11/27/18 7:13 PM, Neels Hofmeyr wrote:
>> Hi Oliver,
>>
>> so I merged the stuff to add the manuals to the individual git repositories,
>> since you said that it works. But when I do --enable-manuals I don't see any
>> PDF files generated. Also a manual 'make pdf' says "nothing to be done".
>>
>> (I probably should have tried it before merging after all)
>>
>> So what am I doing wrong? Alternatively, can you fix it please?
>>
>> ~N
>>
> 

-- 
- Oliver Smith <osmith at sysmocom.de>            https://www.sysmocom.de/
=======================================================================
* sysmocom - systems for mobile communications GmbH
* Alt-Moabit 93
* 10559 Berlin, Germany
* Sitz / Registered office: Berlin, HRB 134158 B
* Geschaeftsfuehrer / Managing Director: Harald Welte


More information about the OpenBSC mailing list