LimeSDR support in osmocom:{nightly,latest} package feeds

Harald Welte laforge at gnumonks.org
Wed Nov 29 18:11:48 UTC 2017


Dear all,

starting from today, we're packaging LimeSuite and (as needed) other
dependencies required for using osmo-trx/osmo-bts-trx with LimeSDR in
the network:osmocom:nightly and network:osmocom:latest feeds.

The package versions are fixed and are not tracking "master" of e.g.
limesuite.  Only the Osmocom packages are tracking master.

Due to the unfortunate fact that the first LimeSuite with osmo-trx
support (17.09.0) requiring a cmake later than what Debian 8 ships,
LimeSDR support is not working with all of the Distributions/Versions
that the rest of the Osmocom stack supports.

It appears that LimeSuite also has some build issues on ARM
architectures, about which I've submitted an upstream bug report at
https://github.com/myriadrf/LimeSuite/issues/151

But at least for x86_64 and i586 architecture, LimeSDR should be
supported by the Osmocom package feeds , on Debian 9.0, Ubuntu 16.04,
16.10, 17.04 and 17.10.

We will shortly use those packages as part of our osmo-gsm-tester setup
at the sysmocom lab, at which point they should receive extensive
testing.

Regards,
	Harald
-- 
- Harald Welte <laforge at gnumonks.org>           http://laforge.gnumonks.org/
============================================================================
"Privacy in residential applications is a desirable marketing option."
                                                  (ETSI EN 300 175-7 Ch. A6)


More information about the OpenBSC mailing list