Error compiling libosmocore under Mac Osx

Juan Antonio Barea Lopez jbarealopez at gmail.com
Tue Jul 12 16:35:20 UTC 2016


Hello all, in order to try grgsm software, it asked for the libosmocore
library and i proceed to configura and install it. Configure process went
ok, but when trying to "make", it gets a error about unidentified symbols.
I have been searching on the web and got several hints that it could be
based on the 64bit version of gcc used. The error in question is this:

**********Output error begins here**********
/Applications/Xcode.app/Contents/Developer/usr/bin/make  all-recursive
Making all in include
make[2]: Nothing to be done for `all'.
Making all in src
/Applications/Xcode.app/Contents/Developer/usr/bin/make  all-am
make[3]: Nothing to be done for `all-am'.
Making all in src/vty
make[2]: Nothing to be done for `all'.
Making all in src/codec
  CCLD     libosmocodec.la
Undefined symbols for architecture x86_64:
  "_bitvec_get_bit_pos", referenced from:
      _osmo_fr_check_sid in gsm610.o
  "_bitvec_get_uint", referenced from:
      _osmo_hr_check_sid in gsm620.o
ld: symbol(s) not found for architecture x86_64
clang: error: linker command failed with exit code 1 (use -v to see
invocation)
make[2]: *** [libosmocodec.la] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2
*********End of output error************
I tried to also made a reconfigure -i but without success. Has anyone
experienced this error or have an idea about what could be happening?.
Thanks in advance!!!!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/openbsc/attachments/20160712/e4eebe3d/attachment.html>


More information about the OpenBSC mailing list