[PATCH] [RFC] src: add prefix osmocom_ to all functions in libosmocore
Pablo Neira Ayuso
pablo at gnumonks.org
Mon Mar 28 17:27:42 CEST 2011
Some minor questions:
On 27/03/11 22:20, Harald Welte wrote:
> * libosmovty should have a common vty_ prefix, but not osmo.
> * for libosmovty we should probably simply limit the number of exported
> symbols. There is e.g. all the buffer_*() and vector_*() use internally,
> but there is no need to globally export all those symbols.
> * no osmo_ prefix for msgb_* and tlv_*, as they are used everywhere
> * no prefix for talloc
> * bitvec_* -> osmo_bv_*
enum bit_value -> enum osmo_bit_value
struct bitvec -> struct osmo_bitvec
> * bsc_*_timer -> osmo_timer_*
there are some inconsistencies in the API naming in the timer bits:
I can put the timer postfix in the end, so it looks consistent.
struct timer_list should be struct osmo_timer_list, right?
> * *_signal_* -> osmo_signal_*
Is there any plan to remove the static lists inside the library?
I can make this in follow up patches. This would require more testing
since it's not a simple renaming.
More information about the OpenBSC