NanoBTS Problem

Stuart Baggs stuart at bluewave.im
Sat Apr 10 13:45:23 CEST 2010


Hi guys, is there a list somwhere which matches versions of openbsc with the required version of libosmocore?

Thanks, Stuart

On 10 Apr 2010, at 12:26, Holger Freyther wrote:

> On Saturday 10 April 2010 13:02:17 Stuart Baggs wrote:
>> I would like to know how to downgrade my openbsc to get this BTS online
>> (just for testing). I tried to use the git commands from Holger, but no
>> luck so far.
>> 
>> $ git bisect start -- openbsc/
>> $ git bisect bad HEAD
>> $ git bisect good 0.9.0
>> 
>> $ cd openbsc/; make (and if I have link errors or such I would downgrade
>> libosmocore too... I would downgrade by checking out the releases).
>> 
>> Is there anyway I can get this BTS setup and working in the short term?
> 
> Well,
> I'm a bit confused. You mentioned that 0.9.0 is not working and now you 
> mention you don't know how to checkout a given version of git? The original 
> message I wrote had two parts:
> 
> 	1.) Consult a git tutorial of your choice
> 	2.) If you want to debug this, use git bisect (you copied this bit).
> 
> 
> Let us assume you want to reset your current branch to an older version you 
> can use the git reset (man git-reset) utility.
> 
> $ git reset --hard TAG|HASH
> 
> TAG can be a tag, e.g. 0.9.0
> HASH can be a sha1 hash of a git commit..
> 
> but the above is no replacement for consulting a git tutorial, and of course 
> if you got back to an older release you might need to install an older version 
> of libosmocore as well.
> 
> 
> 
> 
> 





More information about the OpenBSC mailing list