[op25-dev] Audio to Darkce/IceCast Server - No audio???? No tags, Local audio good.

op25 at zellners.com op25 at zellners.com
Thu Jan 3 01:59:31 UTC 2019


Quoting wllmbecks at gmail.com:

> I trust that you see the process for darkice running.

runs and the silence of the feed plays in vlc, wouldn't play if it was
not mounted to icecast

DarkIce 1.0 live audio streamer, http://code.google.com/p/darkice/
Copyright (c) 2000-2007, Tyrell Hungary, http://tyrell.hu/
Copyright (c) 2008-2010, Akos Maroy and Rafael Diniz
This is free software, and you are welcome to redistribute it
under the terms of The GNU General Public License version 3 or
any later version.

Using config file: redacted.cfg
02-Jan-2019 20:44:13 Using ALSA DSP input device: loop0
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

02-Jan-2019 20:44:13 encoding
02-Jan-2019 20:44:13 scheduler high priority 99
02-Jan-2019 20:44:13 Could not set POSIX real-time scheduling, this
may cause recording skips.
Try to run darkice as the super-user.
02-Jan-2019 20:44:14 set lame mode 3
02-Jan-2019 20:44:14 set lame channels 2
02-Jan-2019 20:44:14 set lame in sample rate 22050
02-Jan-2019 20:44:14 set lame out sample rate 22050
02-Jan-2019 20:44:14 set lame bit rate 16
02-Jan-2019 20:44:14 set lame quality 9
02-Jan-2019 20:44:14 set lame lowpass frequency 5000
02-Jan-2019 20:44:14 set lame highpass frequency 0
02-Jan-2019 20:44:14 set lame psycho acoustic model 1
02-Jan-2019 20:44:14 set lame error protection 1
LAME 3.99.5 32bits (http://lame.sf.net)
Autoconverting from stereo to mono. Setting encoding to mono mode.
Using polyphase lowpass filter, transition band:  5068 Hz -  5335 Hz
02-Jan-2019 20:44:14 MultiThreadedConnector :: tranfer, bytes 0
02-Jan-2019 20:44:14 MultiThreadedConnector :: ThreadData ::
threadFunction, was (thread, priority, type):  0x13e5778 0 SCHED_OTHER
02-Jan-2019 20:44:14 MultiThreadedConnector :: ThreadData ::
threadFunction, now is (thread, priority, type):  0x13e5778 1 SCHED_FIFO



>  I am suspect of your asound.conf.

Compared line by line, the same file for asound
bcm removes one line does essentially the same.

For enumeration, I saved and replaced both asound.conf  and
bcm2835.conf with those attached reboot pi to ensure they load/reload

loopback drivers and devices are the same

   $ cat /proc/modules |grep snd
snd_aloop 24576 2 - Live 0x7f3d2000
snd_bcm2835 32768 0 - Live 0x7f161000 (C)




snd_pcm 98304 3 snd_aloop,snd_bcm2835, Live 0x7f13d000
snd_timer 32768 2 snd_pcm, Live 0x7f12f000
snd 69632 6 snd_aloop,snd_bcm2835,snd_pcm,snd_timer, Live 0x7f114000

$ arecord -l
**** List of CAPTURE Hardware Devices ****
card 1: Loopback [Loopback], device 0: Loopback PCM [Loopback PCM]
    Subdevices: 8/8
    Subdevice #0: subdevice #0
    Subdevice #1: subdevice #1
    Subdevice #2: subdevice #2
    Subdevice #3: subdevice #3
    Subdevice #4: subdevice #4
    Subdevice #5: subdevice #5
    Subdevice #6: subdevice #6
    Subdevice #7: subdevice #7
card 1: Loopback [Loopback], device 1: Loopback PCM [Loopback PCM]
    Subdevices: 7/8
    Subdevice #0: subdevice #0
    Subdevice #1: subdevice #1
    Subdevice #2: subdevice #2
    Subdevice #3: subdevice #3
    Subdevice #4: subdevice #4
    Subdevice #5: subdevice #5
    Subdevice #6: subdevice #6
    Subdevice #7: subdevice #7
pi at raspberrypi:~/darkice $


NO AUDIO still.  Tags... no audio on feed.



More information about the op25-dev mailing list