[op25-dev] WBX or BasicRX ?

Joseph Cardani jcardani at verizon.net
Sat Mar 15 03:45:23 UTC 2014


Hi Marcus,

Yes the libusb version was less that 1.0.9 that was already on the computer, probably from an failed install done several years ago.

thanks,
Joe

On Mar 14, 2014, at 11:42 PM, Marcus D. Leech wrote:

> 
> On 03/14/2014 11:36 PM, ikj1234i at yahoo.com wrote:
>>  
>> Hi Matt ! 
>> 
>> Pleasant surprise to run into you- here's my interpretation of the issue with uhd:  the version of libusb that comes with stock ubuntu 12.04 doesn't define the symbol 'libusb_error_name' - consequently uhd fails to build.  This is all in a pybombs context, btw.  It appears that symbol was defined somewhere around version 1.0.9 of libusb which is newer than what's included in ubuntu 12.04.  Ubuntu 12.04 is listed BTW on the ettus.com site as being one of the supported releases for uhd.
>> 
>> The net-net for end users is that on ubuntu 12.04 if the user attempts to issue the command 
>>    pybombs install gr-op25
>> on a clean ubuntu 12.04 box there is a failure in the step where uhd is being built...  Let me know if I can furnish any other details or if the above is insufficient  / unclear
>> 
>> Best Regards
>> 
>> Max
>> 
> It happens on Fedora systems, too, for libusb < 1.0.9.
> 
> There's a HAVE_LIBUSB_ERROR_NAME variable that is supposed to be set by the cmake, but it isn't set properly always, and the b200_iface.cpp doesn't
>   pick up the proper macro definition.
> 
> This has been identified to the dev team, but I guess not fixed yet.
> 
> 
> 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/op25-dev/attachments/20140314/68b79d0b/attachment.html>


More information about the op25-dev mailing list