[op25-dev] Fwd: error

Joseph Cardani jcardani at verizon.net
Tue Feb 18 17:29:41 UTC 2014


Hi All,

Well I spent 4 hours updating Ubuntu to 12.04 LTS and re-ran the Pybombs installation. I get error at 19% - Make Step Failed for package UHD. Copy of terminal is below.

How do I work around or fix this? 

thanks,
Joe
 

Begin forwarded message:

> From: Joe <jcardani at verizon.net>
> Subject: error
> Date: February 18, 2014 12:24:25 PM EST
> To: jcardani at verizon.net
> 
> joe at joe-desktop:~$ cd pybombs
> joe at joe-desktop:~/pybombs$ dir
> app_store.py	 git-meld.sh	mod_pybombs  recipes		  src
> config.dat	 img		notes.txt    RPCPybombsClient.py  templates
> config.defaults  inventory.dat	pybombs      RPCPybombs.ice
> COPYING		 jenkins.sh	README	     RPCPybombs.py
> joe at joe-desktop:~/pybombs$ ./pybombs install gr-op25
> Settled on prefix: /home/joe/target
> Initializing environmental variables...
> /home/joe/target/python/:/home/joe/target/lib/python2.6/site-packages/:/home/joe/target/lib64/python2.6/site-packages/:/home/joe/target/lib/python2.6/dist-packages/:/home/joe/target/lib64/python2.6/dist-packages/:/home/joe/target/lib/python2.7/site-packages/:/home/joe/target/lib64/python2.7/site-packages/:/home/joe/target/lib/python2.7/dist-packages/:/home/joe/target/lib64/python2.7/dist-packages/:/home/joe/target/python/:/home/joe/target/lib/python2.6/site-packages/:/home/joe/target/lib64/python2.6/site-packages/:/home/joe/target/lib/python2.6/dist-packages/:/home/joe/target/lib64/python2.6/dist-packages/:/home/joe/target/lib/python2.7/site-packages/:/home/joe/target/lib64/python2.7/site-packages/:/home/joe/target/lib/python2.7/dist-packages/:/home/joe/target/lib64/python2.7/dist-packages/
> ---------- loading recipes -------------------
> Loading recipes ...
> Loading recipes ... done
> ---------- loading recipes finished ----------
> 
> checking for gr-op25
> False
> /home/joe/pybombs/mod_pybombs/sysutils.py:588: RuntimeWarning: tempnam
> is a potential security risk to your program
>  tmpfile = os.tempnam(d);
> TMPFILE = /home/joe/target/filejRLyJp
> WRITE PERMS OK /home/joe/target/filejRLyJp
> installing gr-op25
> gr-op25 dep [['gnuradio', 'boost', 'libpcap', 'gr-osmosdr', 'libitpp',
> 'git', 'cmake']]
> gnuradio dep [['make', 'boost', 'fftw', 'cppunit', 'swig', 'gsl', 'uhd',
> 'git', 'python', 'cheetah', 'wxpython', 'numpy', 'lxml', 'pygtk',
> 'pycairo', 'cmake', 'pyqt4', 'pyqwt5', 'gcc', 'ice', 'git', 'cmake']]
> make dep [[]]
> PyBombs.sysutils - INFO - have_deb: Satisfies requirement...installed
> version of make (3.81) is >= than 3.75
> boost dep [['python', 'libbzip', 'wget']]
> fftw dep [['wget']]
> cppunit dep [['wget']]
> swig dep [['python', 'wget', 'gcc']]
> gsl dep [['wget']]
> PyBombs.sysutils - INFO - have_deb: Satisfies requirement...installed
> version of libgsl0-dev (1.15) is >= than 1.13
> PyBombs.sysutils - INFO - have_deb: Satisfies requirement...installed
> version of libgsl0ldbl (1.15) is >= than 1.13
> uhd dep [['make', 'swig', 'python', 'libusb', 'git', 'cmake', 'cheetah',
> 'boost', 'gsl', 'numpy', 'cppunit', 'fftw', 'git', 'cmake']]
> make dep [[]]
> swig dep [['python', 'wget', 'gcc']]
> python dep [['wget']]
> libusb dep [['wget']]
> git dep [['wget', 'curl']]
> cmake dep [['wget']]
> cheetah dep [['python', 'wget', 'python']]
> PyBombs.sysutils - INFO - have_deb: Satisfies requirement...installed
> version of python-cheetah (2.4.4) is >= than 2.0
> boost dep [['python', 'libbzip', 'wget']]
> gsl dep [['wget']]
> numpy dep [['python', 'swig', 'wget', 'python']]
> cppunit dep [['wget']]
> fftw dep [['wget']]
> git dep [['wget', 'curl']]
> cmake dep [['wget']]
> git dep [['wget', 'curl']]
> python dep [['wget']]
> cheetah dep [['python', 'wget', 'python']]
> wxpython dep [['gtk2', 'python', 'swig', 'wget']]
> numpy dep [['python', 'swig', 'wget', 'python']]
> lxml dep [['python', 'libxml', 'libxslt', 'setuptools', 'wget',
> 'python']]
> PyBombs.sysutils - INFO - have_deb: Satisfies requirement...installed
> version of python-lxml (2.3.2) is >= than 2.3.2
> pygtk dep [['python', 'swig', 'gtk2', 'pygobject', 'pango', 'cairo',
> 'wget']]
> PyBombs.sysutils - INFO - have_deb: Satisfies requirement...installed
> version of python-gtk2 (2.24.0) is >= than 2.17
> pycairo dep [['cairo', 'python', 'wget']]
> cairo dep [['fontconfig', 'libpng', 'pixman', 'x11', 'wget']]
> PyBombs.sysutils - INFO - have_deb: Satisfies requirement...installed
> version of libcairo2 (1.10.2) is >= than 1.8.10
> python dep [['wget']]
> wget dep [[]]
> cmake dep [['wget']]
> pyqt4 dep [['python', 'sip', 'qt4', 'wget']]
> PyBombs.sysutils - INFO - have_deb: Satisfies requirement...installed
> version of python-qt4 (4.9.1) is >= than 4.6.2
> pyqwt5 dep [['qwt5', 'pyqt4', 'sip', 'wget']]
> PyBombs.sysutils - INFO - have_deb: Satisfies requirement...installed
> version of python-qwt5-qt4 (5.2.1) is >= than 5.2
> gcc dep [[]]
> ice dep [['swig', 'mcpp', 'db48', 'libbzip', 'expat', 'python', 'wget',
> 'ssl']]
> swig dep [['python', 'wget', 'gcc']]
> mcpp dep [['curl', 'wget']]
> curl dep [[]]
> wget dep [[]]
> db48 dep [['wget']]
> wget dep [[]]
> libbzip dep [['wget']]
> expat dep [['wget']]
> PyBombs.sysutils - INFO - have_deb: Satisfies requirement...installed
> version of libexpat1-dev (2.0.1) is >= than 2.0.1
> python dep [['wget']]
> wget dep [[]]
> ssl dep [[]]
> git dep [['wget', 'curl']]
> cmake dep [['wget']]
> boost dep [['python', 'libbzip', 'wget']]
> libpcap dep [[]]
> gr-osmosdr dep [['uhd', 'rtl-sdr', 'osmo-sdr', 'hackrf', 'gnuradio',
> 'gr-iqbal', 'git', 'cmake']]
> uhd dep [['make', 'swig', 'python', 'libusb', 'git', 'cmake', 'cheetah',
> 'boost', 'gsl', 'numpy', 'cppunit', 'fftw', 'git', 'cmake']]
> make dep [[]]
> swig dep [['python', 'wget', 'gcc']]
> python dep [['wget']]
> libusb dep [['wget']]
> git dep [['wget', 'curl']]
> cmake dep [['wget']]
> cheetah dep [['python', 'wget', 'python']]
> boost dep [['python', 'libbzip', 'wget']]
> gsl dep [['wget']]
> numpy dep [['python', 'swig', 'wget', 'python']]
> cppunit dep [['wget']]
> fftw dep [['wget']]
> git dep [['wget', 'curl']]
> cmake dep [['wget']]
> rtl-sdr dep [['libusb', 'git', 'cmake']]
> libusb dep [['wget']]
> git dep [['wget', 'curl']]
> cmake dep [['wget']]
> osmo-sdr dep [['git', 'cmake', 'libusb', 'git', 'cmake']]
> git dep [['wget', 'curl']]
> cmake dep [['wget']]
> libusb dep [['wget']]
> git dep [['wget', 'curl']]
> cmake dep [['wget']]
> hackrf dep [['git', 'cmake', 'libusb', 'git', 'cmake']]
> git dep [['wget', 'curl']]
> cmake dep [['wget']]
> libusb dep [['wget']]
> git dep [['wget', 'curl']]
> cmake dep [['wget']]
> gnuradio dep [['make', 'boost', 'fftw', 'cppunit', 'swig', 'gsl', 'uhd',
> 'git', 'python', 'cheetah', 'wxpython', 'numpy', 'lxml', 'pygtk',
> 'pycairo', 'cmake', 'pyqt4', 'pyqwt5', 'gcc', 'ice', 'git', 'cmake']]
> make dep [[]]
> boost dep [['python', 'libbzip', 'wget']]
> fftw dep [['wget']]
> cppunit dep [['wget']]
> swig dep [['python', 'wget', 'gcc']]
> gsl dep [['wget']]
> uhd dep [['make', 'swig', 'python', 'libusb', 'git', 'cmake', 'cheetah',
> 'boost', 'gsl', 'numpy', 'cppunit', 'fftw', 'git', 'cmake']]
> make dep [[]]
> swig dep [['python', 'wget', 'gcc']]
> python dep [['wget']]
> libusb dep [['wget']]
> git dep [['wget', 'curl']]
> cmake dep [['wget']]
> cheetah dep [['python', 'wget', 'python']]
> boost dep [['python', 'libbzip', 'wget']]
> gsl dep [['wget']]
> numpy dep [['python', 'swig', 'wget', 'python']]
> cppunit dep [['wget']]
> fftw dep [['wget']]
> git dep [['wget', 'curl']]
> cmake dep [['wget']]
> git dep [['wget', 'curl']]
> python dep [['wget']]
> cheetah dep [['python', 'wget', 'python']]
> wxpython dep [['gtk2', 'python', 'swig', 'wget']]
> numpy dep [['python', 'swig', 'wget', 'python']]
> lxml dep [['python', 'libxml', 'libxslt', 'setuptools', 'wget',
> 'python']]
> pygtk dep [['python', 'swig', 'gtk2', 'pygobject', 'pango', 'cairo',
> 'wget']]
> pycairo dep [['cairo', 'python', 'wget']]
> cairo dep [['fontconfig', 'libpng', 'pixman', 'x11', 'wget']]
> python dep [['wget']]
> wget dep [[]]
> cmake dep [['wget']]
> pyqt4 dep [['python', 'sip', 'qt4', 'wget']]
> pyqwt5 dep [['qwt5', 'pyqt4', 'sip', 'wget']]
> gcc dep [[]]
> ice dep [['swig', 'mcpp', 'db48', 'libbzip', 'expat', 'python', 'wget',
> 'ssl']]
> swig dep [['python', 'wget', 'gcc']]
> mcpp dep [['curl', 'wget']]
> curl dep [[]]
> wget dep [[]]
> db48 dep [['wget']]
> wget dep [[]]
> libbzip dep [['wget']]
> expat dep [['wget']]
> python dep [['wget']]
> wget dep [[]]
> ssl dep [[]]
> git dep [['wget', 'curl']]
> cmake dep [['wget']]
> gr-iqbal dep [['gnuradio', 'libosmo-dsp', 'git', 'cmake']]
> gnuradio dep [['make', 'boost', 'fftw', 'cppunit', 'swig', 'gsl', 'uhd',
> 'git', 'python', 'cheetah', 'wxpython', 'numpy', 'lxml', 'pygtk',
> 'pycairo', 'cmake', 'pyqt4', 'pyqwt5', 'gcc', 'ice', 'git', 'cmake']]
> make dep [[]]
> boost dep [['python', 'libbzip', 'wget']]
> fftw dep [['wget']]
> cppunit dep [['wget']]
> swig dep [['python', 'wget', 'gcc']]
> gsl dep [['wget']]
> uhd dep [['make', 'swig', 'python', 'libusb', 'git', 'cmake', 'cheetah',
> 'boost', 'gsl', 'numpy', 'cppunit', 'fftw', 'git', 'cmake']]
> make dep [[]]
> swig dep [['python', 'wget', 'gcc']]
> python dep [['wget']]
> libusb dep [['wget']]
> git dep [['wget', 'curl']]
> cmake dep [['wget']]
> cheetah dep [['python', 'wget', 'python']]
> boost dep [['python', 'libbzip', 'wget']]
> gsl dep [['wget']]
> numpy dep [['python', 'swig', 'wget', 'python']]
> cppunit dep [['wget']]
> fftw dep [['wget']]
> git dep [['wget', 'curl']]
> cmake dep [['wget']]
> git dep [['wget', 'curl']]
> python dep [['wget']]
> cheetah dep [['python', 'wget', 'python']]
> wxpython dep [['gtk2', 'python', 'swig', 'wget']]
> numpy dep [['python', 'swig', 'wget', 'python']]
> lxml dep [['python', 'libxml', 'libxslt', 'setuptools', 'wget',
> 'python']]
> pygtk dep [['python', 'swig', 'gtk2', 'pygobject', 'pango', 'cairo',
> 'wget']]
> pycairo dep [['cairo', 'python', 'wget']]
> cairo dep [['fontconfig', 'libpng', 'pixman', 'x11', 'wget']]
> python dep [['wget']]
> wget dep [[]]
> cmake dep [['wget']]
> pyqt4 dep [['python', 'sip', 'qt4', 'wget']]
> pyqwt5 dep [['qwt5', 'pyqt4', 'sip', 'wget']]
> gcc dep [[]]
> ice dep [['swig', 'mcpp', 'db48', 'libbzip', 'expat', 'python', 'wget',
> 'ssl']]
> swig dep [['python', 'wget', 'gcc']]
> mcpp dep [['curl', 'wget']]
> curl dep [[]]
> wget dep [[]]
> db48 dep [['wget']]
> wget dep [[]]
> libbzip dep [['wget']]
> expat dep [['wget']]
> python dep [['wget']]
> wget dep [[]]
> ssl dep [[]]
> git dep [['wget', 'curl']]
> cmake dep [['wget']]
> libosmo-dsp dep [['fftw', 'autoconf', 'libtool', 'automake', 'git']]
> fftw dep [['wget']]
> autoconf dep [[]]
> libtool dep [[]]
> automake dep [[]]
> git dep [['wget', 'curl']]
> git dep [['wget', 'curl']]
> cmake dep [['wget']]
> git dep [['wget', 'curl']]
> cmake dep [['wget']]
> libitpp dep [[]]
> git dep [['wget', 'curl']]
> cmake dep [['wget']]
> packages to install: ['uhd', 'pycairo', 'mcpp', 'db48', 'ice',
> 'gnuradio', 'rtl-sdr', 'osmo-sdr', 'hackrf', 'libosmo-dsp', 'gr-iqbal',
> 'gr-osmosdr', 'gr-op25']
> install called (uhd)
> install type priority: ['deb', 'src']
> install deb called (uhd)
> no deb satisfiers available
> install src called (uhd)
> state = configure
> Current step: (uhd :: make)
> make
> ('\n    make -j4\n', '\n    make -j$makewidth\n')
> ('\n    make -j4\n', '\n    make -j4\n')
> bash exec (/home/joe/pybombs/src/uhd/host/build):: 
>    make -j4
> 
> [  4%] [ 12%] [ 12%] Built target doxygen_docs
> Built target man_page_gzips
> Built target manual_html
> [ 12%] [ 13%] [ 13%] [ 14%] Building CXX object
> lib/CMakeFiles/uhd.dir/usrp/b200/b200_iface.cpp.o
> Building CXX object lib/CMakeFiles/uhd.dir/utils/images.cpp.o
> Building CXX object lib/CMakeFiles/uhd.dir/utils/load_modules.cpp.o
> Building CXX object lib/CMakeFiles/uhd.dir/utils/log.cpp.o
> [ 14%] Building CXX object lib/CMakeFiles/uhd.dir/utils/msg.cpp.o
> [ 15%] Building CXX object lib/CMakeFiles/uhd.dir/utils/paths.cpp.o
> [ 15%] Building CXX object lib/CMakeFiles/uhd.dir/utils/static.cpp.o
> [ 15%] Building CXX object lib/CMakeFiles/uhd.dir/utils/tasks.cpp.o
> [ 16%] Building CXX object
> lib/CMakeFiles/uhd.dir/utils/thread_priority.cpp.o
> [ 16%] Building CXX object lib/CMakeFiles/uhd.dir/deprecated.cpp.o
> [ 17%] Building CXX object lib/CMakeFiles/uhd.dir/device.cpp.o
> [ 17%] Building CXX object lib/CMakeFiles/uhd.dir/stream.cpp.o
> [ 18%] Building CXX object lib/CMakeFiles/uhd.dir/exception.cpp.o
> [ 18%] Building CXX object lib/CMakeFiles/uhd.dir/property_tree.cpp.o
> [ 19%] make[2]: *** No rule to make target `/usr/lib/libusb-1.0.so',
> needed by `lib/libuhd.so.003.006'.  Stop.
> make[2]: *** Waiting for unfinished jobs....
> Building CXX object lib/CMakeFiles/uhd.dir/version.cpp.o
> make[1]: *** [lib/CMakeFiles/uhd.dir/all] Error 2
> make: *** [all] Error 2
> ERROR:root:PyBOMBS Make step failed for package (uhd) please see bash
> output above for a reason (hint: look for the word Error)
> joe at joe-desktop:~/pybombs$
> 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/op25-dev/attachments/20140218/e0a5a117/attachment.html>


More information about the op25-dev mailing list