CS Fallback in NextEPC

Romeu Medeiros medeiros at medeiros.eng.br
Fri Jul 19 19:58:00 UTC 2019


Hello Rafael

I just configure the NextEPC to connect via SGS to OSMO-MSC, like this:

    sgsap:
        addr: 127.0.0.1
        port: 29118
        name: vlr.example.net
        tai:
           plmn_id:
             mcc: 724
             mnc: 21
           tac: 12345
        lai:
           plmn_id:
             mcc: 724
             mnc: 4
           lac: 51544

And the configuration in the MSC:

sgs
 local-port 29118
 local-ip 0.0.0.0
 vlr-name vlr.example.net

And configure the IMSI in the Osmo-HLR and NextEPC-HSS

If you need more help tell me.


Thanks

Romeu Medeiros


And

On Fri, Jul 19, 2019 at 1:31 PM Rafael Diniz <rafael at rhizomatica.org> wrote:

> Hi all,
>
> I'd also like to test SMS and CSFB in LTE. I have some experience with
> the Osmocom GSM stack, but not much with the NextEPC LTE. Could you
> point me which fields should I set in the configuration files?
>
> Thanks,
> Rafael Diniz
>
> On 7/13/19 6:35 PM, Romeu Medeiros wrote:
> > Hello Sukchan and friends.
> >
> > I'm trying to use the CSFB in test lab, and every time that nextepc send
> > the UEContextModificationRequest, the UE respond with an
> > UEContextModificationFaliure [ Protocol-cause=semantic-error ].
> >
> > image.png
> >
> > I'm looking why I'm getting this. Someone have any idea?
> >
> > Thanks
> >
> > Romeu Medeiros
> >
> > On Thu, Jul 11, 2019 at 12:15 PM Sukchan Lee <acetcom at gmail.com
> > <mailto:acetcom at gmail.com>> wrote:
> >
> >     Dear Osmocom & NextEPC Community,
> >
> >     Today I've added CS Fallback and released NextEPC v0.5.0
> >
> >     So, I'd just like to test this part with Osmocom project, but it
> >     seems to be a difficult task. The reason is why I have little
> >     knowledge about 2G/3G. Nevertheless, I will try to do it
> >
> >     BTW, I don't know if there is anyone who wants to integrate this big
> >     thing.
> >     Even though I'm not sure if this will help, but let me introduce the
> >     configuration of the NextEPC.
> >
> >     To use SGsAP, change the mme.conf as follows:
> >
> >     #
> >     #  <sgsap>
> >     #
> >     #  o Single MSC/VLR
> >     #    sgsap:
> >     #      addr: 127.0.0.2
> >     #      plmn_id:
> >     #        mcc: 001
> >     #        mnc: 01
> >     #      tac: 4130
> >     #      lac: 43690
> >     #
> >     #  o Multiple MSC/VLR
> >     #    sgsap:
> >     #      - addr: 127.0.0.2
> >     #        plmn_id:
> >     #          mcc: 001
> >     #          mnc: 01
> >     #        tac: 4131
> >     #        lac: 43692
> >     #      - addr
> >     #         - 127.0.0.3
> >     #         - fe80::2%lo0
> >     #        plmn_id:
> >     #          mcc: 001
> >     #          mnc: 01
> >     #        tac: 4132
> >     #        lac: 43692
> >     #      - name: msc.open5gs.org <http://msc.open5gs.org>
> >     #        plmn_id:
> >     #          mcc: 001
> >     #          mnc: 01
> >     #        tac: 4133
> >     #        lac: 43693
> >     #
> >
> >     FYI, I also attach the pcap that I run with nextepc simulator as
> below.
> >
> >     $ ./tests/testcsfb
> >     mo-idle-test        : SUCCESS
> >     mt-idle-test        : SUCCESS
> >     mo-active-test      : SUCCESS
> >     mt-active-test      : SUCCESS
> >     All tests passed.
> >
> >     Feel free to raise any questions about this things.
> >
> >     Best Regards,
> >         Sukchan
> >
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/nextepc/attachments/20190719/72078c96/attachment.html>


More information about the nextepc mailing list