Dectmon only recording data partially?

Patrick McHardy kaber at trash.net
Mon Nov 15 15:25:10 UTC 2010


On 15.11.2010 16:19, Patrick McHardy wrote:
> On 15.11.2010 16:14, Erik Tews wrote:
>> However, I don't get a lock just in PP mode, if I don't use the monitor
>> flag:
>>
>> [607158.216667] com_on_air_pci 0000:02:04.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
>> [607158.216679] com_on_air_pci 0000:02:04.0: setting latency timer to 64
>> [607158.241899] com_on_air_pci 0000:02:04.0: Loading firmware ...
>> [607158.788708] identities information: e: 0 class: 0 emc: 11d3 fpn: 0f371 rpn: 0
>> [607192.974449] identities information: e: 0 class: 0 emc: 11d3 fpn: 0f371 rpn: 0
>> [607219.881092] identities information: e: 0 class: 0 emc: 11d3 fpn: 0f371 rpn: 0
>> [607232.329542] identities information: e: 0 class: 0 emc: 11d3 fpn: 0f371 rpn: 0
>> [607263.615645] identities information: e: 0 class: 0 emc: 11d3 fpn: 0f371 rpn: 0
>> [607283.483168] identities information: e: 0 class: 0 emc: 11d3 fpn: 0f371 rpn: 0
>> [607287.032726] identities information: e: 0 class: 0 emc: 11d3 fpn: 0f371 rpn: 0
>> [607298.211337] identities information: e: 0 class: 0 emc: 11d3 fpn: 0f371 rpn: 0
>> [607307.220212] identities information: e: 0 class: 0 emc: 11d3 fpn: 0f371 rpn: 0
>> [607370.522330] identities information: e: 0 class: 0 emc: 11d3 fpn: 0f371 rpn: 0
> 
> The timings indicate that it only receives very few frames from the
> FP. Is it possible that it's operating in ECO-mode?


One more thing you could try (I had the same problem occasionally, but
it always magically disappeared at some point) is to change
drivers/dect/coa/sc1442x.c and remove SC1442X_BC5_DO_FR from the
BMC configuration. That sometimes helped in my case.





More information about the linux-dect mailing list