<p style="white-space: pre-wrap; word-wrap: break-word;">-1 for missing talloc_strdup(). Didn't notice this before...</p><p>Patch set 11:<span style="border-radius: 3px; display: inline-block; margin: 0 2px; padding: 4px;background-color: #ffd4d4;">Code-Review -1</span></p><p><a href="https://gerrit.osmocom.org/13515">View Change</a></p><p>3 comments:</p><ul style="list-style: none; padding: 0;"><li style="margin: 0; padding: 0;"><p><a href="https://gerrit.osmocom.org/#/c/13515/11/src/gsup_router.c">File src/gsup_router.c:</a></p><ul style="list-style: none; padding: 0;"><li style="margin: 0; padding: 0 0 0 16px;"><p style="margin-bottom: 4px;"><a href="https://gerrit.osmocom.org/#/c/13515/11/src/gsup_router.c@54">Patch Set #11, Line 54:</a> <code style="font-family:monospace,monospace">struct</code></p><p style="white-space: pre-wrap; word-wrap: break-word;">just noticed (cosmetic, not a merge blocker): const.</p></li></ul></li><li style="margin: 0; padding: 0;"><p><a href="https://gerrit.osmocom.org/#/c/13515/11/src/hlr_ussd.c">File src/hlr_ussd.c:</a></p><ul style="list-style: none; padding: 0;"><li style="margin: 0; padding: 0 0 0 16px;"><p style="margin-bottom: 4px;"><a href="https://gerrit.osmocom.org/#/c/13515/11/src/hlr_ussd.c@542">Patch Set #11, Line 542:</a> <code style="font-family:monospace,monospace">gsup_rt->addr</code></p><p style="white-space: pre-wrap; word-wrap: break-word;">I think you also need to use talloc_strdup() here, so this would be consistent with ss_gsup_send(). Otherwise somebody would shoot himself / herself in the foot calling talloc_free().</p></li><li style="margin: 0; padding: 0 0 0 16px;"><p style="margin-bottom: 4px;"><a href="https://gerrit.osmocom.org/#/c/13515/11/src/hlr_ussd.c@546">Patch Set #11, Line 546:</a> <code style="font-family:monospace,monospace">else</code></p><p style="white-space: pre-wrap; word-wrap: break-word;">Please use the { ... } brackets here too, so readability++.</p></li></ul></li></ul><p>To view, visit <a href="https://gerrit.osmocom.org/13515">change 13515</a>. To unsubscribe, or for help writing mail filters, visit <a href="https://gerrit.osmocom.org/settings">settings</a>.</p><div itemscope itemtype="http://schema.org/EmailMessage"><div itemscope itemprop="action" itemtype="http://schema.org/ViewAction"><link itemprop="url" href="https://gerrit.osmocom.org/13515"/><meta itemprop="name" content="View Change"/></div></div>

<div style="display:none"> Gerrit-Project: osmo-hlr </div>
<div style="display:none"> Gerrit-Branch: master </div>
<div style="display:none"> Gerrit-MessageType: comment </div>
<div style="display:none"> Gerrit-Change-Id: If5a65f471672949192061c5fe396603611123bc1 </div>
<div style="display:none"> Gerrit-Change-Number: 13515 </div>
<div style="display:none"> Gerrit-PatchSet: 11 </div>
<div style="display:none"> Gerrit-Owner: osmith <osmith@sysmocom.de> </div>
<div style="display:none"> Gerrit-Reviewer: Jenkins Builder (1000002) </div>
<div style="display:none"> Gerrit-Reviewer: Neels Hofmeyr <nhofmeyr@sysmocom.de> </div>
<div style="display:none"> Gerrit-Reviewer: Vadim Yanitskiy <axilirator@gmail.com> </div>
<div style="display:none"> Gerrit-Reviewer: osmith <osmith@sysmocom.de> </div>
<div style="display:none"> Gerrit-Comment-Date: Tue, 09 Apr 2019 11:29:28 +0000 </div>
<div style="display:none"> Gerrit-HasComments: Yes </div>
<div style="display:none"> Gerrit-HasLabels: Yes </div>