Change in osmo-bsc[master]: fix TSC / TSC Set used for Handover

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

fixeria gerrit-no-reply at lists.osmocom.org
Sat Oct 2 20:13:27 UTC 2021


fixeria has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-bsc/+/25659 )

Change subject: fix TSC / TSC Set used for Handover
......................................................................


Patch Set 2: Code-Review+1

(3 comments)

https://gerrit.osmocom.org/c/osmo-bsc/+/25659/2/include/osmocom/bsc/gsm_data.h 
File include/osmocom/bsc/gsm_data.h:

https://gerrit.osmocom.org/c/osmo-bsc/+/25659/2/include/osmocom/bsc/gsm_data.h@144 
PS2, Line 144: struct optional_val {
Might be a good idea to generalize this API and have it in libosmocore:

  #define OSMO_OPTFIELD(ftype, fname) \
    struct { \
      bool present; \
      ftype val; \
    } name;

so then one could use it with various types:

  struct foo {
    OSMO_OPTFIELD(struct bar_t, bar);
    OSMO_OPTFIELD(struct zoo_t, zoo);
    OSMO_OPTFIELD(uint32_t, counter);
  }

What do you think?


https://gerrit.osmocom.org/c/osmo-bsc/+/25659/2/include/osmocom/bsc/gsm_data.h@145 
PS2, Line 145: use
I would call it 'valid' or even 'present'. Not critical though.


https://gerrit.osmocom.org/c/osmo-bsc/+/25659/2/include/osmocom/bsc/gsm_data.h@629 
PS2, Line 629: 	bool ta_known;
Idea for a separate change: use 'struct optional_val' here too.



-- 
To view, visit https://gerrit.osmocom.org/c/osmo-bsc/+/25659
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings

Gerrit-Project: osmo-bsc
Gerrit-Branch: master
Gerrit-Change-Id: Iae20df4387c3d75752301bd5daeeea7508966393
Gerrit-Change-Number: 25659
Gerrit-PatchSet: 2
Gerrit-Owner: neels <nhofmeyr at sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: fixeria <vyanitskiy at sysmocom.de>
Gerrit-Comment-Date: Sat, 02 Oct 2021 20:13:27 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/gerrit-log/attachments/20211002/2a553c69/attachment.htm>


More information about the gerrit-log mailing list