Change in osmo-pcu[master]: Rename function s/tbf_alloc_ul/tbf_alloc_ul_pacch/

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

pespin gerrit-no-reply at lists.osmocom.org
Tue May 11 09:43:11 UTC 2021


pespin has submitted this change. ( https://gerrit.osmocom.org/c/osmo-pcu/+/24188 )

Change subject: Rename function s/tbf_alloc_ul/tbf_alloc_ul_pacch/
......................................................................

Rename function s/tbf_alloc_ul/tbf_alloc_ul_pacch/

Change-Id: I70ca0b5be0a29a05c6e65b9c92cc6d3b5c43d3dc
---
M src/pdch.cpp
M src/tbf_ul.cpp
M src/tbf_ul.h
3 files changed, 5 insertions(+), 5 deletions(-)

Approvals:
  pespin: Looks good to me, approved
  Jenkins Builder: Verified



diff --git a/src/pdch.cpp b/src/pdch.cpp
index 5389763..c69c45c 100644
--- a/src/pdch.cpp
+++ b/src/pdch.cpp
@@ -119,7 +119,7 @@
 	bts_do_rate_ctr_inc(bts, CTR_CHANNEL_REQUEST_DESCRIPTION);
 
 	/* This call will register the new TBF with the MS on success */
-	gprs_rlcmac_ul_tbf *ul_tbf = tbf_alloc_ul(bts, tbf->ms(), tbf->trx->trx_no, tbf->tlli());
+	gprs_rlcmac_ul_tbf *ul_tbf = tbf_alloc_ul_pacch(bts, tbf->ms(), tbf->trx->trx_no, tbf->tlli());
 
 	/* schedule uplink assignment or reject */
 	if (ul_tbf) {
@@ -683,7 +683,7 @@
 			tbf_free(ul_tbf);
 		}
 
-		ul_tbf = tbf_alloc_ul(bts(), ms, trx_no(), tlli);
+		ul_tbf = tbf_alloc_ul_pacch(bts(), ms, trx_no(), tlli);
 		if (!ul_tbf) {
 			handle_tbf_reject(bts(), ms, trx_no(), ts_no);
 			goto return_unref;
diff --git a/src/tbf_ul.cpp b/src/tbf_ul.cpp
index c41793d..cf8c75c 100644
--- a/src/tbf_ul.cpp
+++ b/src/tbf_ul.cpp
@@ -141,7 +141,7 @@
 }
 
 /* Alloc a UL TBF to be assigned over PACCH */
-gprs_rlcmac_ul_tbf *tbf_alloc_ul(struct gprs_rlcmac_bts *bts, GprsMs *ms, int8_t use_trx,
+gprs_rlcmac_ul_tbf *tbf_alloc_ul_pacch(struct gprs_rlcmac_bts *bts, GprsMs *ms, int8_t use_trx,
 				 uint32_t tlli)
 {
 	struct gprs_rlcmac_ul_tbf *tbf;
diff --git a/src/tbf_ul.h b/src/tbf_ul.h
index 53c7ad8..4207deb 100644
--- a/src/tbf_ul.h
+++ b/src/tbf_ul.h
@@ -118,8 +118,8 @@
 }
 
 struct gprs_rlcmac_ul_tbf *tbf_alloc_ul_tbf(struct gprs_rlcmac_bts *bts, GprsMs *ms, int8_t use_trx, bool single_slot);
-struct gprs_rlcmac_ul_tbf *tbf_alloc_ul(struct gprs_rlcmac_bts *bts, GprsMs *ms,
-					int8_t use_trx, uint32_t tlli);
+struct gprs_rlcmac_ul_tbf *tbf_alloc_ul_pacch(struct gprs_rlcmac_bts *bts, GprsMs *ms,
+					      int8_t use_trx, uint32_t tlli);
 struct gprs_rlcmac_ul_tbf *handle_tbf_reject(struct gprs_rlcmac_bts *bts,
 	GprsMs *ms, uint8_t trx_no, uint8_t ts_no);
 

-- 
To view, visit https://gerrit.osmocom.org/c/osmo-pcu/+/24188
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings

Gerrit-Project: osmo-pcu
Gerrit-Branch: master
Gerrit-Change-Id: I70ca0b5be0a29a05c6e65b9c92cc6d3b5c43d3dc
Gerrit-Change-Number: 24188
Gerrit-PatchSet: 2
Gerrit-Owner: pespin <pespin at sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: pespin <pespin at sysmocom.de>
Gerrit-CC: fixeria <vyanitskiy at sysmocom.de>
Gerrit-MessageType: merged
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/gerrit-log/attachments/20210511/51e69d41/attachment.htm>


More information about the gerrit-log mailing list