Change in osmo-mgw[master]: mgcp_trunk: use unsigned int instead of int as trunk_nr

dexter gerrit-no-reply at lists.osmocom.org
Tue Jul 20 14:40:30 UTC 2021


Hello Jenkins Builder, 

I'd like you to reexamine a change. Please visit

    https://gerrit.osmocom.org/c/osmo-mgw/+/24963

to look at the new patch set (#2).

Change subject: mgcp_trunk: use unsigned int instead of int as trunk_nr
......................................................................

mgcp_trunk: use unsigned int instead of int as trunk_nr

the trunk_nr is in struct mgcp_trunk. The trunk number can not be
negative and there is no magic value that makes use of the fact that it
could be negative. Lets use unsigned int to make this less irretating.

Change-Id: I5d0e1d76adb8c92d84331a0aca2496908e41d621
Related: SYS#5535
---
M include/osmocom/mgcp/mgcp_trunk.h
M src/libosmo-mgcp/mgcp_endp.c
M src/libosmo-mgcp/mgcp_ratectr.c
M src/libosmo-mgcp/mgcp_trunk.c
M src/libosmo-mgcp/mgcp_vty.c
M src/osmo-mgw/mgw_main.c
M tests/mgcp/mgcp_test.c
7 files changed, 63 insertions(+), 52 deletions(-)


  git pull ssh://gerrit.osmocom.org:29418/osmo-mgw refs/changes/63/24963/2
-- 
To view, visit https://gerrit.osmocom.org/c/osmo-mgw/+/24963
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings

Gerrit-Project: osmo-mgw
Gerrit-Branch: master
Gerrit-Change-Id: I5d0e1d76adb8c92d84331a0aca2496908e41d621
Gerrit-Change-Number: 24963
Gerrit-PatchSet: 2
Gerrit-Owner: dexter <pmaier at sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-MessageType: newpatchset
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/gerrit-log/attachments/20210720/2d411ca3/attachment.htm>


More information about the gerrit-log mailing list