Change in libosmocore[master]: gprs_bssgp_rim: add functions to convert a RIM-RI to a string

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

dexter gerrit-no-reply at lists.osmocom.org
Tue Jan 26 15:20:41 UTC 2021


dexter has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmocore/+/22438 )

Change subject: gprs_bssgp_rim: add functions to convert a RIM-RI to a string
......................................................................


Patch Set 2:

(3 comments)

https://gerrit.osmocom.org/c/libosmocore/+/22438/1/src/gb/gprs_bssgp_rim.c 
File src/gb/gprs_bssgp_rim.c:

https://gerrit.osmocom.org/c/libosmocore/+/22438/1/src/gb/gprs_bssgp_rim.c@156 
PS1, Line 156: 	static __thread char rai_buf[32];
> why don't you allocate these in the stack?
oh, now I see, thats of course unnecessary.


https://gerrit.osmocom.org/c/libosmocore/+/22438/1/src/gb/gprs_bssgp_rim.c@158 
PS1, Line 158: 	static __thread char en_bid_buf[16];
> You have 2 buffers but you use up to 2 only in each branch, so you can declare only 2 buffers.
I want to have dedicated buffers to make the code more readable, now they are on the stack, so I think we can afford that extra memory now.


https://gerrit.osmocom.org/c/libosmocore/+/22438/1/src/gb/gprs_bssgp_rim.c@173 
PS1, Line 173: 			 osmo_rai_name2_buf(rai_buf, sizeof(rai_buf), &rai), ri->geran.cid);
> There's osmo_cgi_ps_name family of APIs for this
Done



-- 
To view, visit https://gerrit.osmocom.org/c/libosmocore/+/22438
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings

Gerrit-Project: libosmocore
Gerrit-Branch: master
Gerrit-Change-Id: Idca6bdccffe663aea71a0183ca3ea5bb5b59e702
Gerrit-Change-Number: 22438
Gerrit-PatchSet: 2
Gerrit-Owner: dexter <pmaier at sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge at osmocom.org>
Gerrit-Reviewer: pespin <pespin at sysmocom.de>
Gerrit-Comment-Date: Tue, 26 Jan 2021 15:20:41 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: pespin <pespin at sysmocom.de>
Gerrit-MessageType: comment
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/gerrit-log/attachments/20210126/28c0fc0f/attachment.htm>


More information about the gerrit-log mailing list