Change in pysim[master]: ts_31_102.py: add EF_ADF_map

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

guilly@gmail.com gerrit-no-reply at lists.osmocom.org
Fri May 29 12:32:58 UTC 2020


guilly at gmail.com has posted comments on this change. ( https://gerrit.osmocom.org/c/pysim/+/18564 )

Change subject: ts_31_102.py: add EF_ADF_map
......................................................................


Patch Set 2:

(5 comments)

> Patch Set 2:
> 
> (1 comment)

https://gerrit.osmocom.org/c/pysim/+/18564/1/pySim/cards.py 
File pySim/cards.py:

https://gerrit.osmocom.org/c/pysim/+/18564/1/pySim/cards.py@a228 
PS1, Line 228: '3f00', '2f00'
> Are you sure about this change? It's not just '2f00', but with '3f00'.
yes, that's taken from the EF, which ends up being
'DIR':    [MF_num, EF_num['DIR']]

so just a cosmetic change


https://gerrit.osmocom.org/c/pysim/+/18564/2/pySim/cards.py 
File pySim/cards.py:

https://gerrit.osmocom.org/c/pysim/+/18564/2/pySim/cards.py@228 
PS2, Line 228: (EF['DIR'])
> Again, is this correct? […]
EF['DIR'] is coming from here (ts_51_011.py)

EF = {
'ICCID':  [MF_num, EF_num['ICCID']],
'ELP':    [MF_num, EF_num['ELP']],
'DIR':    [MF_num, EF_num['DIR']],

which ends up being the same values (unless I am missing something else?)


https://gerrit.osmocom.org/c/pysim/+/18564/1/pySim/ts_31_102.py 
File pySim/ts_31_102.py:

https://gerrit.osmocom.org/c/pysim/+/18564/1/pySim/ts_31_102.py@141 
PS1, Line 141: 'LI': '6F05',
> Please align it with tabs: […]
Ack


https://gerrit.osmocom.org/c/pysim/+/18564/2/pySim/ts_31_102.py 
File pySim/ts_31_102.py:

https://gerrit.osmocom.org/c/pysim/+/18564/2/pySim/ts_31_102.py@140 
PS2, Line 140: EF_ADF_map = {
> it would be great to have it renamed it as EF_USIM_ADF_map as there is also ISIM ADF as well. […]
shoudln't that go in the other file, as it's in a different spec?


https://gerrit.osmocom.org/c/pysim/+/18564/1/pySim/ts_51_011.py 
File pySim/ts_51_011.py:

https://gerrit.osmocom.org/c/pysim/+/18564/1/pySim/ts_51_011.py@45 
PS1, Line 45: 
> Unrelated change.
Ack



-- 
To view, visit https://gerrit.osmocom.org/c/pysim/+/18564
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings

Gerrit-Project: pysim
Gerrit-Branch: master
Gerrit-Change-Id: I458380bf46b2986662ecdede2551c22cd9be92ba
Gerrit-Change-Number: 18564
Gerrit-PatchSet: 2
Gerrit-Owner: guilly at gmail.com <guilly at gmail.com>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: fixeria <axilirator at gmail.com>
Gerrit-Reviewer: guilly at gmail.com <guilly at gmail.com>
Gerrit-CC: herlesupreeth <herlesupreeth at gmail.com>
Gerrit-Comment-Date: Fri, 29 May 2020 12:32:58 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: fixeria <axilirator at gmail.com>
Comment-In-Reply-To: herlesupreeth <herlesupreeth at gmail.com>
Gerrit-MessageType: comment
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/gerrit-log/attachments/20200529/1a760a80/attachment.htm>


More information about the gerrit-log mailing list