Change in osmo-bts[master]: osmo-bts-trx/scheduler: refactor UL burst measurement processing

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

pespin gerrit-no-reply at lists.osmocom.org
Tue Jun 23 09:29:51 UTC 2020


pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-bts/+/18973 )

Change subject: osmo-bts-trx/scheduler: refactor UL burst measurement processing
......................................................................


Patch Set 2:

(4 comments)

https://gerrit.osmocom.org/c/osmo-bts/+/18973/2/include/osmo-bts/scheduler.h 
File include/osmo-bts/scheduler.h:

https://gerrit.osmocom.org/c/osmo-bts/+/18973/2/include/osmo-bts/scheduler.h@132 
PS2, Line 132: 		unsigned int idx;
missing documentation for this field idx (not lear what's its purpose).


https://gerrit.osmocom.org/c/osmo-bts/+/18973/2/src/osmo-bts-trx/sched_lchan_tchf.c 
File src/osmo-bts-trx/sched_lchan_tchf.c:

https://gerrit.osmocom.org/c/osmo-bts/+/18973/2/src/osmo-bts-trx/sched_lchan_tchf.c@203 
PS2, Line 203: 	 * TODO: properly handle measurements in DTX mode */
Is this adding a regression?


https://gerrit.osmocom.org/c/osmo-bts/+/18973/2/src/osmo-bts-trx/scheduler_trx.c 
File src/osmo-bts-trx/scheduler_trx.c:

https://gerrit.osmocom.org/c/osmo-bts/+/18973/2/src/osmo-bts-trx/scheduler_trx.c@377 
PS2, Line 377: 	unsigned int current = chan_state->meas.idx;
so idx points to the next "free" slot. Would be great renaming it to something more meaningful, at least "next_idx".


https://gerrit.osmocom.org/c/osmo-bts/+/18973/2/src/osmo-bts-trx/scheduler_trx.c@413 
PS2, Line 413: 		n = 6; shift = n;
So you are keeping both n and shift having same value and they don't change later. Why do you need both?



-- 
To view, visit https://gerrit.osmocom.org/c/osmo-bts/+/18973
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings

Gerrit-Project: osmo-bts
Gerrit-Branch: master
Gerrit-Change-Id: I2b02b51fea5664f161382a4ddc63dbf14ffc9ac5
Gerrit-Change-Number: 18973
Gerrit-PatchSet: 2
Gerrit-Owner: fixeria <vyanitskiy at sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-CC: pespin <pespin at sysmocom.de>
Gerrit-Comment-Date: Tue, 23 Jun 2020 09:29:51 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/gerrit-log/attachments/20200623/8d753550/attachment.htm>


More information about the gerrit-log mailing list