Change in osmo-pcu[master]: Use boolean for DL resegmentation parameter

Harald Welte gerrit-no-reply at lists.osmocom.org
Tue Mar 19 13:15:11 UTC 2019


Harald Welte has posted comments on this change. ( https://gerrit.osmocom.org/13057 )

Change subject: Use boolean for DL resegmentation parameter
......................................................................


Patch Set 3: Code-Review-1

> > there is no downlink arq type "true" or "false".  While I agree i
 > fthere are only two discrete values you should use a type with only
 > two options, but if those optionsare not something that can be
 > "true" or "false", using bool is just as wrong as using int, isn't
 > it?
 > 
 > I'm not sure I'm following.
 > 
 > In 44.060 §8.1.1 there's 'resegment bit' which could be 0 (type 2
 > ARQ) or 1 (type 1 ARQ). So it's boolean value. That's also how it's
 > used throughout the code so far.

I'm not arguing that this bit has a true or false value, like any bit.

However, the variable used in osmo-pcu is called "downlink ARQ type",
and clearly there is no type==true or type==false here, right?

 > In general, RLCMAC might operate in non-persistent (MBMS bearer,
 > 43.246) acknowledged (types 1 and 2 above) and unacknowledged (no
 > ARQ) modes according to TS 43.064 §6.6.4.5 and §6.6.4.6.
 > 
 > So when would we want to use some 3rd value for dl_arq_type and
 > which spec describes that case? 

I'm not saying we want to use a third value.  I'm saying if a variable
is not named like it is a yes/no or true/false condition, then either
the varialbe must be named differntly to use bool, or the type must
be changed from bool to enum.

>Or, in other words, if we make
 > 'enum dl_arq_type', which would be the values for it besides TYPE1
 > and TYPE2?
 
no other types.


-- 
To view, visit https://gerrit.osmocom.org/13057
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings

Gerrit-Project: osmo-pcu
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: I4d4fe5fe12068a4532cb3b61d4eeb229a77c1476
Gerrit-Change-Number: 13057
Gerrit-PatchSet: 3
Gerrit-Owner: Max <msuraev at sysmocom.de>
Gerrit-Reviewer: Daniel Willmann <dwillmann at sysmocom.de>
Gerrit-Reviewer: Harald Welte <laforge at gnumonks.org>
Gerrit-Reviewer: Jenkins Builder (1000002)
Gerrit-Reviewer: Max <msuraev at sysmocom.de>
Gerrit-Reviewer: Pau Espin Pedrol <pespin at sysmocom.de>
Gerrit-Reviewer: osmith <osmith at sysmocom.de>
Gerrit-Comment-Date: Tue, 19 Mar 2019 13:15:11 +0000
Gerrit-HasComments: No
Gerrit-HasLabels: Yes
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/gerrit-log/attachments/20190319/c0e19b6a/attachment.html>


More information about the gerrit-log mailing list