Change in libosmocore[master]: Make rate_ctr_group_free() more robust

Vadim Yanitskiy gerrit-no-reply at lists.osmocom.org
Tue Mar 19 09:16:42 UTC 2019


Vadim Yanitskiy has posted comments on this change. ( https://gerrit.osmocom.org/13303 )

Change subject: Make rate_ctr_group_free() more robust
......................................................................


Patch Set 1:

(2 comments)

https://gerrit.osmocom.org/#/c/13303/1//COMMIT_MSG
Commit Message:

https://gerrit.osmocom.org/#/c/13303/1//COMMIT_MSG@7
PS1, Line 7: more robust
IMHO, such commit name is meaningless. Don't get me wrong.
Let's just imagine the following commit log:

  - Make function_a() work better
  - Make function_b() more stable
  - ...

In general, all our commits make something more robust,
better, and so on. What about a more concrete naming?


https://gerrit.osmocom.org/#/c/13303/1//COMMIT_MSG@9
PS1, Line 9: Properly check and handle empty or NULL input.
This is exactly what I would like to see in the commit name.
Alternatively: rate_ctr_group_free(): guard against empty or NULL input.



-- 
To view, visit https://gerrit.osmocom.org/13303
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings

Gerrit-Project: libosmocore
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: I859a91ee4400b3685c05971f8c66bceca6758724
Gerrit-Change-Number: 13303
Gerrit-PatchSet: 1
Gerrit-Owner: Max <msuraev at sysmocom.de>
Gerrit-Reviewer: Jenkins Builder (1000002)
Gerrit-CC: Harald Welte <laforge at gnumonks.org>
Gerrit-CC: Vadim Yanitskiy <axilirator at gmail.com>
Gerrit-Comment-Date: Tue, 19 Mar 2019 09:16:42 +0000
Gerrit-HasComments: Yes
Gerrit-HasLabels: No
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/gerrit-log/attachments/20190319/b9c35253/attachment.html>


More information about the gerrit-log mailing list