Change in libosmocore[master]: add osmo_use_count API
gerrit-no-reply at lists.osmocom.org
Fri Mar 15 04:04:22 UTC 2019
Neels Hofmeyr has posted comments on this change. ( https://gerrit.osmocom.org/13121 )
Change subject: add osmo_use_count API
Patch Set 3:
In the end I kept the naming the same, while spreading a lot more documentation to clarify. The outer struct could be called "osmo_use_count_list", but semantically, it represents *the* use count of this object, which happens to be fragmented into separate named tokens with a portion of the counts for each token. Each token has a 'use' (a name) and a 'count', which IMHO can't be improved upon naming wise. Suggestions welcome. (I also like how 'use' and 'count' make 'use count' ;)
PS2, Line 205: * \param[in] file Source file path, as in __FILE__.
> ACK. […]
NACK, I disagree with describing all arguments here. The reason is that this is the kind of private implementation handle for the actual osmo_use_count_get_put() API, and writing out all arguments will be an exact copy of the description in osmo_use_count_get_put(). Add a few patches here and there, and very soon both will be out of sync. I will not introduce such a copy for function signatures that are so obviously one and the same.
Having 'change' vs 'diff' isn't harmful, but I can change that if you insist. I can diff that if you insist.
To view, visit https://gerrit.osmocom.org/13121
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings
Gerrit-Owner: Neels Hofmeyr <nhofmeyr at sysmocom.de>
Gerrit-Reviewer: Harald Welte <laforge at gnumonks.org>
Gerrit-Reviewer: Jenkins Builder (1000002)
Gerrit-Reviewer: Neels Hofmeyr <nhofmeyr at sysmocom.de>
Gerrit-Reviewer: Pau Espin Pedrol <pespin at sysmocom.de>
Gerrit-Reviewer: Vadim Yanitskiy <axilirator at gmail.com>
Gerrit-CC: Max <msuraev at sysmocom.de>
Gerrit-Comment-Date: Fri, 15 Mar 2019 04:04:22 +0000
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the gerrit-log