Change in libosmocore[master]: add osmo_ip_port API

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

Neels Hofmeyr gerrit-no-reply at lists.osmocom.org
Mon Mar 4 23:53:48 UTC 2019


Hello Jenkins Builder, 

I'd like you to reexamine a change. Please visit

    https://gerrit.osmocom.org/13123

to look at the new patch set (#4).

Change subject: add osmo_ip_port API
......................................................................

add osmo_ip_port API

For handling RTP IP addresses and ports, osmo-mgw, osmo-bsc and osmo-msc so far
have their own separate shims and code duplication around inet_ntoa(), htons(),
sockaddr conversions etc. Unify and standardize with this common API.

In the MGW endpoint FSM that was introduced in osmo-bsc and which I would like
to re-use for osmo-msc (upcoming patch moving that to osmo-mgw), it has turned
out that using char* IP address and uint16_t port number types are a convenient
common denominator for logging, MGCP message composition and GSM48. Ongoing
osmo-msc work also uses this for MNCC.

This is of course potentially useful for any other IP+port combinations besides
RTP stream handling.

Needless to say that most current implementations will probably stay with their
current own conversion code for a long time; for current osmo-{bsc,msc,mgw}
work (MGW endpoint FSM) though, I would like to move to this API here.

Change-Id: Id617265337f09dfb6ddfe111ef5e578cd3dc9f63
---
M configure.ac
M include/Makefile.am
A include/osmocom/core/ip_port.h
M src/Makefile.am
A src/ip_port.c
M tests/Makefile.am
A tests/ip_port/ip_port_test.c
A tests/ip_port/ip_port_test.ok
M tests/testsuite.at
9 files changed, 1,007 insertions(+), 1 deletion(-)


  git pull ssh://gerrit.osmocom.org:29418/libosmocore refs/changes/23/13123/4
-- 
To view, visit https://gerrit.osmocom.org/13123
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings

Gerrit-Project: libosmocore
Gerrit-Branch: master
Gerrit-MessageType: newpatchset
Gerrit-Change-Id: Id617265337f09dfb6ddfe111ef5e578cd3dc9f63
Gerrit-Change-Number: 13123
Gerrit-PatchSet: 4
Gerrit-Owner: Neels Hofmeyr <nhofmeyr at sysmocom.de>
Gerrit-Reviewer: Jenkins Builder (1000002)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/gerrit-log/attachments/20190304/017032dd/attachment.htm>


More information about the gerrit-log mailing list