Change in gr-gsm[master]: python/trx: rename 'change_sign_of_dict_elements' to 'dict_toggle_sign'

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

Vadim Yanitskiy gerrit-no-reply at lists.osmocom.org
Wed Jan 16 10:13:44 UTC 2019


Vadim Yanitskiy has uploaded this change for review. ( https://gerrit.osmocom.org/12575


Change subject: python/trx: rename 'change_sign_of_dict_elements' to 'dict_toggle_sign'
......................................................................

python/trx: rename 'change_sign_of_dict_elements' to 'dict_toggle_sign'

The old name was quite long, resulting into cumbersome imports:

  from change_sign_of_dict_elements import change_sign_of_dict_elements

let's use a shorter variant:

  from dict_toggle_sign import dict_toggle_sign

Change-Id: Ie75e1d6e5e74c7c1cf34154633c1472e4b85dbb6
---
M python/trx/CMakeLists.txt
M python/trx/__init__.py
R python/trx/dict_toggle_sign.py
M python/trx/radio_if_grc.py
4 files changed, 7 insertions(+), 7 deletions(-)



  git pull ssh://gerrit.osmocom.org:29418/gr-gsm refs/changes/75/12575/1

diff --git a/python/trx/CMakeLists.txt b/python/trx/CMakeLists.txt
index c6e3010..ffe5234 100644
--- a/python/trx/CMakeLists.txt
+++ b/python/trx/CMakeLists.txt
@@ -26,6 +26,6 @@
     fake_pm.py
     radio_if.py
     radio_if_grc.py
-    change_sign_of_dict_elements.py
+    dict_toggle_sign.py
     DESTINATION ${GR_PYTHON_DIR}/grgsm/trx
 )
diff --git a/python/trx/__init__.py b/python/trx/__init__.py
index 372f46b..fda783e 100644
--- a/python/trx/__init__.py
+++ b/python/trx/__init__.py
@@ -26,4 +26,4 @@
 from fake_pm import fake_pm
 from radio_if_grc import radio_if_grc
 from radio_if import radio_if
-from change_sign_of_dict_elements import change_sign_of_dict_elements
+from dict_toggle_sign import dict_toggle_sign
diff --git a/python/trx/change_sign_of_dict_elements.py b/python/trx/dict_toggle_sign.py
similarity index 94%
rename from python/trx/change_sign_of_dict_elements.py
rename to python/trx/dict_toggle_sign.py
index fd7c585..d6cd8bd 100644
--- a/python/trx/change_sign_of_dict_elements.py
+++ b/python/trx/dict_toggle_sign.py
@@ -9,7 +9,7 @@
 from gnuradio import gr
 from pmt import *
 
-class change_sign_of_dict_elements(gr.basic_block):
+class dict_toggle_sign(gr.basic_block):
     def __init__(self):  # only default arguments here
         gr.basic_block.__init__(
             self,
diff --git a/python/trx/radio_if_grc.py b/python/trx/radio_if_grc.py
index 920b0c5..8a92f6e 100755
--- a/python/trx/radio_if_grc.py
+++ b/python/trx/radio_if_grc.py
@@ -8,7 +8,7 @@
 # Generated: Fri Dec  1 10:49:25 2017
 ##################################################
 
-from change_sign_of_dict_elements import change_sign_of_dict_elements
+from dict_toggle_sign import dict_toggle_sign
 from gnuradio import blocks
 from gnuradio import digital
 from gnuradio import eng_notation
@@ -94,16 +94,16 @@
         self.gsm_burst_type_filter_0 = grgsm.burst_type_filter(([3]))
         self.gsm_burst_to_fn_time_0 = grgsm.burst_to_fn_time()
         self.digital_burst_shaper_xx_0 = digital.burst_shaper_cc((firdes.window(firdes.WIN_HANN, 16, 0)), 0, 20, False, "packet_len")
-        self.change_sign_of_dict_elements = change_sign_of_dict_elements()
+        self.dict_toggle_sign = dict_toggle_sign()
         self.blocks_pdu_to_tagged_stream_0_0 = blocks.pdu_to_tagged_stream(blocks.byte_t, "packet_len")
 
         ##################################################
         # Connections
         ##################################################
-        self.msg_connect((self.change_sign_of_dict_elements, 'dict_out'), (self.gsm_msg_to_tag_0_0, 'msg'))    
+        self.msg_connect((self.dict_toggle_sign, 'dict_out'), (self.gsm_msg_to_tag_0_0, 'msg'))
         self.msg_connect((self.gsm_burst_to_fn_time_0, 'fn_time_out'), (self.gsm_txtime_setter_0, 'fn_time'))    
         self.msg_connect((self.gsm_burst_type_filter_0, 'bursts_out'), (self.gsm_burst_to_fn_time_0, 'bursts_in'))    
-        self.msg_connect((self.gsm_clock_offset_control_0, 'ctrl'), (self.change_sign_of_dict_elements, 'dict_in'))    
+        self.msg_connect((self.gsm_clock_offset_control_0, 'ctrl'), (self.dict_toggle_sign, 'dict_in'))
         self.msg_connect((self.gsm_clock_offset_control_0, 'ctrl'), (self.gsm_msg_to_tag_0, 'msg'))    
         self.msg_connect((self.gsm_preprocess_tx_burst_0, 'bursts_out'), (self.blocks_pdu_to_tagged_stream_0_0, 'pdus'))    
         self.msg_connect((self.gsm_receiver_0, 'C0'), (self.gsm_burst_type_filter_0, 'bursts_in'))    

-- 
To view, visit https://gerrit.osmocom.org/12575
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings

Gerrit-Project: gr-gsm
Gerrit-Branch: master
Gerrit-MessageType: newchange
Gerrit-Change-Id: Ie75e1d6e5e74c7c1cf34154633c1472e4b85dbb6
Gerrit-Change-Number: 12575
Gerrit-PatchSet: 1
Gerrit-Owner: Vadim Yanitskiy <axilirator at gmail.com>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/gerrit-log/attachments/20190116/b8c93e75/attachment.htm>


More information about the gerrit-log mailing list