Change in libosmocore[master]: gsm0808: add message generator for BSSMAP HANDOVER PERFORMED

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

dexter gerrit-no-reply at lists.osmocom.org
Fri Nov 30 10:16:46 UTC 2018


dexter has posted comments on this change. ( https://gerrit.osmocom.org/11728 )

Change subject: gsm0808: add message generator for BSSMAP HANDOVER PERFORMED
......................................................................


Patch Set 6:

(6 comments)

> I mean gsm0808_create_handover_performed() of course.

As far as I can see this is the LCLS-BSS-Status. I have added it now so you can use it right away.

https://gerrit.osmocom.org/#/c/11728/4/include/osmocom/gsm/gsm0808.h
File include/osmocom/gsm/gsm0808.h:

https://gerrit.osmocom.org/#/c/11728/4/include/osmocom/gsm/gsm0808.h@174
PS4, Line 174: 	struct gsm0808_cell_id cell_id;
> (in osmo-bsc it is usually called "cell_id")
Done


https://gerrit.osmocom.org/#/c/11728/4/include/osmocom/gsm/gsm0808.h@186
PS4, Line 186: 	struct gsm0808_speech_codec speech_codec_chosen;
> in above structs we have a 'bool more_items' to allow backwards compatible extensions to this struct […]
Done


https://gerrit.osmocom.org/#/c/11728/1/src/gsm/gsm0808.c
File src/gsm/gsm0808.c:

https://gerrit.osmocom.org/#/c/11728/1/src/gsm/gsm0808.c@894
PS1, Line 894: 
> frankly I'm not sure at all; and also it seems we don't really care about big endian after all... […]
Done


https://gerrit.osmocom.org/#/c/11728/1/src/gsm/gsm0808.c@897
PS1, Line 897: 
> the gsm0808_create_layer3 precedes the cell identity encoding API. […]
Done


https://gerrit.osmocom.org/#/c/11728/4/src/gsm/gsm0808.c
File src/gsm/gsm0808.c:

https://gerrit.osmocom.org/#/c/11728/4/src/gsm/gsm0808.c@913
PS4, Line 913: 	msgb_tlv_put(msg, GSM0808_IE_CAUSE, gsm0808_cause_ext(params->cause) ? 2 : 1, (const uint8_t *)&params->cause);
> Yes, it does - at least it's the same IE. […]
I see, we should add a helper function that adds a cause. This line is not really well readable and the ?-Notation does not help either in this case. I will fix this, also for the other functions.


https://gerrit.osmocom.org/#/c/11728/4/src/gsm/gsm0808.c@926
PS4, Line 926: 	/* Speech Version (chosen) 3.2.2.51 */
> Chosen: Parseltounge […]
Done



-- 
To view, visit https://gerrit.osmocom.org/11728
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings

Gerrit-Project: libosmocore
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: I825106858bd89afc9837811b8fed2e8accc82441
Gerrit-Change-Number: 11728
Gerrit-PatchSet: 6
Gerrit-Owner: dexter <pmaier at sysmocom.de>
Gerrit-Reviewer: Jenkins Builder (1000002)
Gerrit-Reviewer: Max <msuraev at sysmocom.de>
Gerrit-Reviewer: Neels Hofmeyr <nhofmeyr at sysmocom.de>
Gerrit-Reviewer: dexter <pmaier at sysmocom.de>
Gerrit-CC: Pau Espin Pedrol <pespin at sysmocom.de>
Gerrit-Comment-Date: Fri, 30 Nov 2018 10:16:46 +0000
Gerrit-HasComments: Yes
Gerrit-HasLabels: No
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/gerrit-log/attachments/20181130/f67bb774/attachment.htm>


More information about the gerrit-log mailing list