Change in osmo-gsm-manuals[master]: move OsmoMSC files to osmo-msc.git

Neels Hofmeyr gerrit-no-reply at lists.osmocom.org
Wed Nov 21 13:03:31 UTC 2018


Neels Hofmeyr has posted comments on this change. ( https://gerrit.osmocom.org/11738 )

Change subject: move OsmoMSC files to osmo-msc.git
......................................................................


Patch Set 7: Code-Review+2

(4 comments)

In general I think spreading out the removals over numerous patches adds little more than effort. Does it matter how we move the files? The end result will be that they are gone from here, and it's not like looking at file removals is confusing, i.e. splitting up doesn't really make anything more easy to read, does it?

Ok, to revert a single repos would be easier with single patches, but I doubt we'll do that, and I doubt even if that it's worth the extra effort (including time spent on moving doc patches that are being written while this refactoring is in limbo)

I accept opinions, but would prefer if we could get this done sooner rather than later, and avoid treading out more bikeshed issues more than we have already...

https://gerrit.osmocom.org/#/c/11738/7//COMMIT_MSG
Commit Message:

https://gerrit.osmocom.org/#/c/11738/7//COMMIT_MSG@7
PS7, Line 7: move OsmoMSC files to osmo-msc.git
> You are not moving them here, you are removing them from osmo-gsm-manuals. […]
(IMHO "move" is better, because that's semantically what we're doing. but either way is fine.)


https://gerrit.osmocom.org/#/c/11738/7//COMMIT_MSG@9
PS7, Line 9: Add to osmo-msc.git with I2f9c27f81940b02414f0e618483bffade72e8cf7.
> Is this Change-Id part of osmo-msc.git? […]
(IMHO also this is fine. but so is pau's version)


https://gerrit.osmocom.org/#/c/11738/7//COMMIT_MSG@14
PS7, Line 14: Related: OS#3385
> Depends: osmo-msc. […]
if this build breaks without that osmo-msc commit, 'Depends:' is accurate. I guess it's more like 'Related:'?


https://gerrit.osmocom.org/#/c/11738/7/Makefile.am
File Makefile.am:

https://gerrit.osmocom.org/#/c/11738/7/Makefile.am@8
PS7, Line 8: SUBDIRS = tests OsmoBSC OsmoBTS OsmoGGSN OsmoGSMTester OsmoHLR OsmoMGCP OsmoMGW OsmoNAT OsmoNITB OsmoPCU \
> Would make sense to split this line into a multiline with \, since we'll be changing it a lot in fol […]
(IMHO this is not needed)



-- 
To view, visit https://gerrit.osmocom.org/11738
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings

Gerrit-Project: osmo-gsm-manuals
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: Ib234fe4f4ac36c27a4ad8a8d0050c1d6874232bc
Gerrit-Change-Number: 11738
Gerrit-PatchSet: 7
Gerrit-Owner: osmith <osmith at sysmocom.de>
Gerrit-Reviewer: Jenkins Builder (1000002)
Gerrit-Reviewer: Neels Hofmeyr <nhofmeyr at sysmocom.de>
Gerrit-Reviewer: Pau Espin Pedrol <pespin at sysmocom.de>
Gerrit-Reviewer: osmith <osmith at sysmocom.de>
Gerrit-Comment-Date: Wed, 21 Nov 2018 13:03:31 +0000
Gerrit-HasComments: Yes
Gerrit-HasLabels: Yes
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/gerrit-log/attachments/20181121/6b5f254f/attachment.html>


More information about the gerrit-log mailing list