Change in osmo-bsc[master]: Rename bsc_msg_acc_lst_vty_init to have more uniform prefix

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

Pau Espin Pedrol gerrit-no-reply at lists.osmocom.org
Thu Jun 28 10:59:05 UTC 2018


Pau Espin Pedrol has uploaded this change for review. ( https://gerrit.osmocom.org/9764


Change subject: Rename bsc_msg_acc_lst_vty_init to have more uniform prefix
......................................................................

Rename bsc_msg_acc_lst_vty_init to have more uniform prefix

Change-Id: I6f125d040a8f511590ef67ba8babbd2e01c6bf21
---
M include/osmocom/bsc/bsc_msg_filter.h
M src/libfilter/bsc_msg_vty.c
M src/osmo-bsc/osmo_bsc_main.c
3 files changed, 3 insertions(+), 3 deletions(-)



  git pull ssh://gerrit.osmocom.org:29418/osmo-bsc refs/changes/64/9764/1

diff --git a/include/osmocom/bsc/bsc_msg_filter.h b/include/osmocom/bsc/bsc_msg_filter.h
index 2740905..fe87485 100644
--- a/include/osmocom/bsc/bsc_msg_filter.h
+++ b/include/osmocom/bsc/bsc_msg_filter.h
@@ -99,5 +99,5 @@
 struct bsc_msg_acc_lst_entry *bsc_msg_acc_lst_entry_create(struct bsc_msg_acc_lst *);
 int bsc_msg_acc_lst_check_allow(struct bsc_msg_acc_lst *lst, const char *imsi);
 
-void bsc_msg_lst_vty_init(void *ctx, struct llist_head *lst, int node);
+void bsc_msg_acc_lst_vty_init(void *ctx, struct llist_head *lst, int node);
 void bsc_msg_acc_lst_write(struct vty *vty);
diff --git a/src/libfilter/bsc_msg_vty.c b/src/libfilter/bsc_msg_vty.c
index bcee37e..9905365 100644
--- a/src/libfilter/bsc_msg_vty.c
+++ b/src/libfilter/bsc_msg_vty.c
@@ -135,7 +135,7 @@
 	}
 }
 
-void bsc_msg_lst_vty_init(void *ctx, struct llist_head *lst, int node)
+void bsc_msg_acc_lst_vty_init(void *ctx, struct llist_head *lst, int node)
 {
 	_ctx = ctx;
 	_acc_lst = lst;
diff --git a/src/osmo-bsc/osmo_bsc_main.c b/src/osmo-bsc/osmo_bsc_main.c
index 1f951b1..9ee5147 100644
--- a/src/osmo-bsc/osmo_bsc_main.c
+++ b/src/osmo-bsc/osmo_bsc_main.c
@@ -803,7 +803,7 @@
 	/* This needs to precede handle_options() */
 	vty_init(&vty_info);
 	bsc_vty_init(bsc_gsmnet);
-	bsc_msg_lst_vty_init(tall_bsc_ctx, &access_lists, BSC_NODE);
+	bsc_msg_acc_lst_vty_init(tall_bsc_ctx, &access_lists, BSC_NODE);
 	ctrl_vty_init(tall_bsc_ctx);
 	logging_vty_add_deprecated_subsys(tall_bsc_ctx, "cc");
 	logging_vty_add_deprecated_subsys(tall_bsc_ctx, "mgcp");

-- 
To view, visit https://gerrit.osmocom.org/9764
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings

Gerrit-Project: osmo-bsc
Gerrit-Branch: master
Gerrit-MessageType: newchange
Gerrit-Change-Id: I6f125d040a8f511590ef67ba8babbd2e01c6bf21
Gerrit-Change-Number: 9764
Gerrit-PatchSet: 1
Gerrit-Owner: Pau Espin Pedrol <pespin at sysmocom.de>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/gerrit-log/attachments/20180628/d5085d7d/attachment.htm>


More information about the gerrit-log mailing list