Change in libosmo-sccp[master]: rename m3ua_example to sccp_test

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

Stefan Sperling gerrit-no-reply at lists.osmocom.org
Thu Jun 14 09:11:06 UTC 2018


Stefan Sperling has uploaded this change for review. ( https://gerrit.osmocom.org/9628


Change subject: rename m3ua_example to sccp_test
......................................................................

rename m3ua_example to sccp_test

The new name allows for more natural naming of variables in TTCN3
code when this program is used as a TTCN3 test component.
Consider e.g. "SCCP_TEST_VTY" vs. "M3UA_EXAMPLE_VTY".

Change-Id: I92b5e16e765a1ac36371a16933389903628f8dfe
---
M .gitignore
M examples/Makefile.am
R examples/sccp_test.c
3 files changed, 5 insertions(+), 5 deletions(-)



  git pull ssh://gerrit.osmocom.org:29418/libosmo-sccp refs/changes/28/9628/1

diff --git a/.gitignore b/.gitignore
index e63e4ee..f1356a7 100644
--- a/.gitignore
+++ b/.gitignore
@@ -60,7 +60,7 @@
 tests/testsuite
 tests/testsuite.log
 
-examples/m3ua_example
+examples/sccp_test
 
 stp/osmo-stp
 
diff --git a/examples/Makefile.am b/examples/Makefile.am
index 6418aca..d000d67 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -4,8 +4,8 @@
 
 noinst_HEADERS = internal.h
 
-noinst_PROGRAMS = m3ua_example
+noinst_PROGRAMS = sccp_test
 
-m3ua_example_SOURCES = m3ua_example.c sccp_test_server.c sccp_test_vty.c
-m3ua_example_LDADD = $(top_builddir)/src/libosmo-sigtran.la \
+sccp_test_SOURCES = sccp_test.c sccp_test_server.c sccp_test_vty.c
+sccp_test_LDADD = $(top_builddir)/src/libosmo-sigtran.la \
 		   $(LIBOSMOCORE_LIBS) $(LIBOSMOVTY_LIBS)
diff --git a/examples/m3ua_example.c b/examples/sccp_test.c
similarity index 98%
rename from examples/m3ua_example.c
rename to examples/sccp_test.c
index 2a99450..4989bf6 100644
--- a/examples/m3ua_example.c
+++ b/examples/sccp_test.c
@@ -90,7 +90,7 @@
 #define DEFAULT_REMOTE_PORT	M3UA_PORT
 
 static void usage(void) {
-	fprintf(stderr, "m3ua_example [-c] [-l LOCAL_ADDRESS[:LOCAL_PORT]]\n"
+	fprintf(stderr, "sccp_test [-c] [-l LOCAL_ADDRESS[:LOCAL_PORT]]\n"
 			"             [-r REMOTE_ADDRESS[:REMOTE_PORT]]\n"
 			"             [-L LOCAL_POINT_CODE] [-R REMOTE_POINT_CODE]\n"
 			"Options:\n"

-- 
To view, visit https://gerrit.osmocom.org/9628
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings

Gerrit-Project: libosmo-sccp
Gerrit-Branch: master
Gerrit-MessageType: newchange
Gerrit-Change-Id: I92b5e16e765a1ac36371a16933389903628f8dfe
Gerrit-Change-Number: 9628
Gerrit-PatchSet: 1
Gerrit-Owner: Stefan Sperling <ssperling at sysmocom.de>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/gerrit-log/attachments/20180614/32e33b0b/attachment.htm>


More information about the gerrit-log mailing list