[MERGED] osmo-bsc[master]: cosmetic: explicitly init ho_ref start value

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

Harald Welte gerrit-no-reply at lists.osmocom.org
Fri Jan 19 22:09:27 UTC 2018


Harald Welte has submitted this change and it was merged.

Change subject: cosmetic: explicitly init ho_ref start value
......................................................................


cosmetic: explicitly init ho_ref start value

The static ho_ref seems to be implicitly initialized to zero, but let's make it
explicit for code readability.

Change-Id: I00493bcb7ef3e38fb8e0077c60c5bac7199f1073
---
M src/libbsc/handover_logic.c
1 file changed, 1 insertion(+), 1 deletion(-)

Approvals:
  Harald Welte: Looks good to me, approved
  Jenkins Builder: Verified



diff --git a/src/libbsc/handover_logic.c b/src/libbsc/handover_logic.c
index ee7b683..4b86de7 100644
--- a/src/libbsc/handover_logic.c
+++ b/src/libbsc/handover_logic.c
@@ -93,7 +93,7 @@
 {
 	struct gsm_lchan *new_lchan;
 	struct bsc_handover *ho;
-	static uint8_t ho_ref;
+	static uint8_t ho_ref = 0;
 	int rc;
 
 	/* don't attempt multiple handovers for the same lchan at

-- 
To view, visit https://gerrit.osmocom.org/5896
To unsubscribe, visit https://gerrit.osmocom.org/settings

Gerrit-MessageType: merged
Gerrit-Change-Id: I00493bcb7ef3e38fb8e0077c60c5bac7199f1073
Gerrit-PatchSet: 4
Gerrit-Project: osmo-bsc
Gerrit-Branch: master
Gerrit-Owner: Neels Hofmeyr <nhofmeyr at sysmocom.de>
Gerrit-Reviewer: Harald Welte <laforge at gnumonks.org>
Gerrit-Reviewer: Jenkins Builder



More information about the gerrit-log mailing list