[PATCH] osmo-msc[master]: Debian: require minimum versions of packages we depend on

Harald Welte gerrit-no-reply at lists.osmocom.org
Sun Oct 29 07:50:35 UTC 2017


Review at  https://gerrit.osmocom.org/4558

Debian: require minimum versions of packages we depend on

I'm using the dame version as in configure.ac to avoid build failures
against older versions of certain packages, such as older libsmpp34.

Change-Id: I83c617fa4e83e2e3d2613e454f517d6031814f21
---
M debian/control
1 file changed, 8 insertions(+), 8 deletions(-)


  git pull ssh://gerrit.osmocom.org:29418/osmo-msc refs/changes/58/4558/1

diff --git a/debian/control b/debian/control
index 12d8364..60d468e 100644
--- a/debian/control
+++ b/debian/control
@@ -11,16 +11,16 @@
                pkg-config,
                libdbi-dev,
                libtalloc-dev,
-               libssl-dev,
-               libsmpp34-dev,
-               libasn1c-dev,
-               libosmocore-dev,
+               libssl-dev (>= 0.9.5),
+               libsmpp34-dev (>= 1.12),
+               libasn1c-dev (>= 0.9.28),
+               libosmocore-dev (>= 0.10.0),
                libosmo-sccp-dev,
-               libosmo-sigtran-dev,
+               libosmo-sigtran-dev (>= 0.8.0),
                libosmo-abis-dev,
-               libosmo-mgcp-client-dev,
-               libosmo-netif-dev,
-               libosmo-ranap-dev
+               libosmo-mgcp-client-dev (>= 1.1.0),
+               libosmo-netif-dev (>= 0.1.0),
+               libosmo-ranap-dev (>= 0.2.0)
 Standards-Version: 3.9.8
 Vcs-Git: git://git.osmocom.org/osmo-msc.git
 Vcs-Browser: https://git.osmocom.org/osmo-msc/

-- 
To view, visit https://gerrit.osmocom.org/4558
To unsubscribe, visit https://gerrit.osmocom.org/settings

Gerrit-MessageType: newchange
Gerrit-Change-Id: I83c617fa4e83e2e3d2613e454f517d6031814f21
Gerrit-PatchSet: 1
Gerrit-Project: osmo-msc
Gerrit-Branch: master
Gerrit-Owner: Harald Welte <laforge at gnumonks.org>


More information about the gerrit-log mailing list