[MERGED] osmo-trx[master]: Call vectorSlicer() right before packing bits for transmissi...

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

Alexander Chemeris gerrit-no-reply at lists.osmocom.org
Wed Mar 22 18:33:12 UTC 2017


Alexander Chemeris has submitted this change and it was merged.

Change subject: Call vectorSlicer() right before packing bits for transmission to osmo-bts.
......................................................................


Call vectorSlicer() right before packing bits for transmission to osmo-bts.

vectorSlicer() converts soft-bits from -1..+1 to 0..1 while we want
to keep SoftVector in -1..+1 mode until the last minute, because at some
point we'll want to transmit -1..+1 to osmo-bts instead of converting it
from 0..1 back to -1..+1 on the osmo-bts side.

Plus it removes code duplication - we call it once instead of twice.

Change-Id: Idd6ddd7ac219afb0df055a692632678b66373764
---
M Transceiver52M/Transceiver.cpp
M Transceiver52M/sigProcLib.cpp
2 files changed, 3 insertions(+), 3 deletions(-)

Approvals:
  Tom Tsou: Looks good to me, approved
  Jenkins Builder: Verified



diff --git a/Transceiver52M/Transceiver.cpp b/Transceiver52M/Transceiver.cpp
index 3f624d0..85dd629 100644
--- a/Transceiver52M/Transceiver.cpp
+++ b/Transceiver52M/Transceiver.cpp
@@ -962,6 +962,9 @@
   if (!rxBurst)
     return;
 
+  // Convert -1..+1 soft bits to 0..1 soft bits
+  vectorSlicer(rxBurst);
+
   /*
    * EDGE demodulator returns 444 (148 * 3) bits
    */
diff --git a/Transceiver52M/sigProcLib.cpp b/Transceiver52M/sigProcLib.cpp
index 56a1a58..6f50f04 100644
--- a/Transceiver52M/sigProcLib.cpp
+++ b/Transceiver52M/sigProcLib.cpp
@@ -2068,8 +2068,6 @@
   bits = signalToSoftVector(dec);
   delete dec;
 
-  vectorSlicer(bits);
-
   return bits;
 }
 
@@ -2099,7 +2097,6 @@
 
   /* Soft slice and normalize */
   bits = softSliceEdgeBurst(*rot);
-  vectorSlicer(bits);
 
   delete dec;
   delete eq;

-- 
To view, visit https://gerrit.osmocom.org/2139
To unsubscribe, visit https://gerrit.osmocom.org/settings

Gerrit-MessageType: merged
Gerrit-Change-Id: Idd6ddd7ac219afb0df055a692632678b66373764
Gerrit-PatchSet: 4
Gerrit-Project: osmo-trx
Gerrit-Branch: master
Gerrit-Owner: Alexander Chemeris <Alexander.Chemeris at gmail.com>
Gerrit-Reviewer: Alexander Chemeris <Alexander.Chemeris at gmail.com>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: Max <msuraev at sysmocom.de>
Gerrit-Reviewer: Tom Tsou <tom at tsou.cc>



More information about the gerrit-log mailing list