libosmocore[master]: Add osmo_rand() function

Harald Welte gerrit-no-reply at
Fri Jan 6 10:14:02 UTC 2017

Patch Set 1: Code-Review-1

(1 comment)
File src/gsm/gsm_utils.c:

Line 675: 	return gnutls_rnd(GNUTLS_RND_NONCE, out, len);
you're using the NONCE quality here, but the function name doesn't expose this property.  So the API is hiding the detail that the quality of random numbers is e.g. not sufficient for e.g. key generation.  So let's rename t to osmo_rand_nonce to be on the safe side?

To view, visit
To unsubscribe, visit

Gerrit-MessageType: comment
Gerrit-Change-Id: I0241b814ea4c4ce1458f7ad76e31d390383c2048
Gerrit-PatchSet: 1
Gerrit-Project: libosmocore
Gerrit-Branch: master
Gerrit-Owner: Max <msuraev at>
Gerrit-Reviewer: Harald Welte <laforge at>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: Max <msuraev at>
Gerrit-HasComments: Yes

More information about the gerrit-log mailing list