libosmocore[master]: logging: centrally define ctx and filter indexes

Neels Hofmeyr gerrit-no-reply at
Mon Feb 20 14:53:44 UTC 2017

Patch Set 2:

> As this likely to be used very often I'd shorten it to LOGCTX_..
 > and LOGFILTER_.. similar to existing LOGL_.. and LOGP.

Each LOGGING_FILTER_ is basically used twice. The LOGGING_CTX_ is used once per code path that would like to indicate an object to log. It's not *that* often but I see your point that we usually use just 'LOG' as prefix.

The main reason though to pick this long name was to avoid conflicts with previous names. Now that I look at it that's indeed only LOG_FILTER_ALL.

I'd prefer to keep the underscore, so would you be fine with LOG_FLT_ and LOG_CTX_ ?

To view, visit
To unsubscribe, visit

Gerrit-MessageType: comment
Gerrit-Change-Id: I5c343630020f4b108099696fd96c2111614c8067
Gerrit-PatchSet: 2
Gerrit-Project: libosmocore
Gerrit-Branch: master
Gerrit-Owner: Neels Hofmeyr <nhofmeyr at>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: Max <msuraev at>
Gerrit-Reviewer: Neels Hofmeyr <nhofmeyr at>
Gerrit-HasComments: No

More information about the gerrit-log mailing list