[MERGED] libosmocore[master]: control_if: Don't use magic number '5' when allocating vector

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

Harald Welte gerrit-no-reply at lists.osmocom.org
Thu Apr 27 08:30:32 UTC 2017


Harald Welte has submitted this change and it was merged.

Change subject: control_if: Don't use magic number '5' when allocating vector
......................................................................


control_if: Don't use magic number '5' when allocating vector

We have a proper constant for this (_LAST_CTRL_NODE), so let's use it.

Change-Id: I46275e644166156cb665da70d2964008f1c6cd88
---
M src/ctrl/control_if.c
1 file changed, 1 insertion(+), 1 deletion(-)

Approvals:
  Harald Welte: Looks good to me, approved
  Jenkins Builder: Verified



diff --git a/src/ctrl/control_if.c b/src/ctrl/control_if.c
index 6ab34c7..c4b6f91 100644
--- a/src/ctrl/control_if.c
+++ b/src/ctrl/control_if.c
@@ -706,7 +706,7 @@
 	if (ctrl_initialized)
 		return 0;
 
-	ctrl_node_vec = vector_init(5);
+	ctrl_node_vec = vector_init(_LAST_CTRL_NODE);
 	if (!ctrl_node_vec)
 		goto err;
 

-- 
To view, visit https://gerrit.osmocom.org/2379
To unsubscribe, visit https://gerrit.osmocom.org/settings

Gerrit-MessageType: merged
Gerrit-Change-Id: I46275e644166156cb665da70d2964008f1c6cd88
Gerrit-PatchSet: 2
Gerrit-Project: libosmocore
Gerrit-Branch: master
Gerrit-Owner: Harald Welte <laforge at gnumonks.org>
Gerrit-Reviewer: Harald Welte <laforge at gnumonks.org>
Gerrit-Reviewer: Jenkins Builder



More information about the gerrit-log mailing list