[PATCH] Fix and expand bitvec interface.

suraev at alumni.ntnu.no
Thu Jan 14 13:10:30 UTC 2016


14.01.2016 11:23, Harald Welte пишет:

> we generally don't use 'unsigned' in the code so far, but 'unsigned
> int'.  So it's a bit odd to see 'unsigned' without int here.  In
> general, I probably wouldn't care too much.  However, given that it is a
> single function that has one 'unsigned int' and one 'unsigned' argument,
> it seems a bit odd.

I prefer 'unsigned' because it's less to type and neither provides any guarantees
with regards to size of the type. I think size_t and uintXX_t would be better
technically.

On a related note, what's the status of https://patchwork.ozlabs.org/patch/559571/ ?
Cause merging it would result in conflict with this patch so I'd prefer to rebase
mine earlier if possible.

cheers,
Max.




More information about the baseband-devel mailing list