Osmovom-BB on Raspberry Pi

parpar bso at inbox.lv
Fri Jun 13 20:40:56 UTC 2014


Hi

Can anyone elaborate on the "compatible crosscompiled tool-chain"? I
compiled mine (gnu arm toolchain) following these instructions, but it seems
that RSSI and other firmwares compiled on raspberry are crashing (-110 dBm
on all ARFCNs after certain operations - e.g. spectrum view).

Host tools compiled on raspberry seem to work fine (e.g. osmocon loading
firmware compiled on PC). Still they don't quite "talk" with different
firmware version (from PC).


Richard Menedetter wrote
> I tried Motorola C118 and C155 with success.
> 
> Everything you need is already described:
> http://bb.osmocom.org/trac/wiki/GnuArmToolchain
> http://bb.osmocom.org/trac/wiki/libosmocore
> http://bb.osmocom.org/trac/wiki/Software/GettingStarted?redirectedfrom=GettingStarted
> 
> My previous problem seems to have been a not fully compatible
> crosscompiled toolchain. (it worked mostly, but I could not log-in to a
> cell and the spectrum view crashed on the RSSI Firmware.





--
View this message in context: http://baseband-devel.722152.n3.nabble.com/Osmovom-BB-on-Raspberry-Pi-tp4025859p4026518.html
Sent from the baseband-devel mailing list archive at Nabble.com.




More information about the baseband-devel mailing list