bad crc in osmoload [SOLVED!]

Bhaskar11 niceguy108 at gmail.com
Wed May 22 17:27:21 UTC 2013


Solved the "bad crc" problem in Osmoload.

The bug was inadvertently introduced in osmoload.c in update SHA
ID 6ce46e7a86f4de0b1eef9c641ef6cfb49f1255cd on 9.9..2012 when msgb_get()
was replaced by msgb_pull() as part of a large scale change. Looks like no
one else had tried a "osmoload memdump" since then.

Am enclosing patch to fix this bug.

B.



On Tue, May 14, 2013 at 5:26 PM, Bhaskar11 <niceguy108 at gmail.com> wrote:

> Hi all,
>
> I'm trying to flash RSSI app to my C118 following instructions on
> http://bb.osmocom.org/trac/wiki/flashing.
>
> First step Osmocon with loader works fine.
>
> Second step with "osmoload memdump 0x000000 0x2000 compal_loader.bin"
> gives the following output:
>
> Dumping 8192 bytes of memory at 0x0 to file compal_loader.bin
>
> bad crc 4190 (not 0000) at offset 0x00000000
> bad crc f041 (not b209) at offset 0x000000f0
> bad crc f041 (not 79d3) at offset 0x000001e0
> ...
> bad crc f041 (not fe61) at offset 0x00001e00
> bad crc 8257 (not 4cd6) at offset 0x00001ef0
> bad crc a401 (not 0000) at offset 0x00001fe0done.
>
> Would appreciate any guidance on what I can do to set this right.
>
> A general question:
> If I flash RSSI app succesfully, can I later restore the original C118
> code and use the cell as before? (assuming I have saved the full memory
> dump to disk!) Or is that gone for good?
>
> Thanks for your guidance.
>
> B.
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/baseband-devel/attachments/20130522/710c9d94/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0001-Bugfix-in-Osmoload.c-Assigning-correct-value-to-data.patch
Type: application/octet-stream
Size: 935 bytes
Desc: not available
URL: <http://lists.osmocom.org/pipermail/baseband-devel/attachments/20130522/710c9d94/attachment.obj>


More information about the baseband-devel mailing list