about osmocon on gta02 (Solved)

Aegean Chou aegean2000 at 21cn.com
Thu Jun 14 11:02:27 UTC 2012


Hi lists,

	I spend one day, finally solved it myself.

	1) i checked the schematic of gta02 carefully, and found the PCF50633 use GPIO2(gsm_on)
	 to control the power of GSM actually, and it have a test point H-TP1706.

	2) i disassembled my gta02, then line out the H-TP1706 to my oscilloscope, i found the
	gsm_on signal always LOW 1s, and HIGH 4.2s, it's very strange.

	3) i checked the service list, i found the fsogsmd (it's ogsmd?), maybe it's the background
	 program. but i can't kill it.

	4) finally, i try to set "disable = 0" in /etc/frameworkd.conf, reboot, my god, it solved.
	but the http://bb.osmocom.org/trac/wiki/OpenMoko only says:
		“disable ogsmd, ousaged, ophoned via /etc/frameworkd.conf”
	i always think "disable = 1" should DISABLE it.

	but actually, "disable = 0" = DISABLE it; and "disable = 1" = ENABLE it? why
	it misleaded me so long, anybody can change it? thanks.

Aegean

======= 2012-06-14 09:40:32 =======

>Dear lists,
>
>	i want porting rssi and osmocon to GTA02, let them run on GTA02 stand-alone.
>	then i'll try to write a program to decoding the received data.
>
>	i already cross-compiled the latest osmocon to GTA02,
>	then i disabled "ogsmd,ousaged and ophoned" in /etc/frameworkd.conf (actually, them are disabled default),
>	and i commented "device_port and modem_access" in fsogsmd.conf to disable everything accessed to the modem,
>	after rebooting, the "fuser /dev/ttySAC0" shows none.
>
>	but when i use "./osmocon -i 13 -m romload -p /dev/ttySAC0 rssi.highram.bin", and 
>	"echo 0 > /sys/bus/platform/devices/gta02-pm-gsm.0/power_on && echo 1 > ..."
>										  /\ my SHR kernel use this device name for GSM power
>	the osmocon always stalls about at the block 40, for example: 	
>		... ...
>		Preparing block 39, block checksum is 0x4c 
>		handle_write_block(): 1024 bytes (1024/1024)
>		handle_write_block(): Block 39 finished
>		Received block ack from phone
>		Preparing block 40, block checksum is 0xd5 
>		handle_write_block(): 1024 bytes (1024/1024)
>		handle_write_block(): Block 40 finished
>	and i found that the osmocon start to download codes before my "GSM power reset", very strange,
>
>	i tried the latest "SHR-core 20120427" and "unstable SHR-lite 20110822",
>	i searched the list log, found "Dave" encounter the same problem, but he solved it after "re-flashing of the phone"
>	i re-flashed the GSM firmware to latest Moko11 (before it's Moko10), but it's the same.
>
>	BTW, i found that it always shows '1' when "cat /sys/bus/platform/devices/gta02-pm-gsm.0/power_on"
>	even after "echo 0 >/sys/bus/platform/devices/gta02-pm-gsm.0/power_on", what's wrong?
>
>	anyone can help help me?
>	thanks very much.
>
>Best Regards
>Aegean
>2012-06-13
>

= = = = = = = = = = = = = = = = = = = =
			

Best regards
				 
        Aegean Chou
        aegean2000 at 21cn.com
          2012-06-14



More information about the baseband-devel mailing list