AW: Facing issues in using OSMOCOM

Andreas.Eversberg Andreas.Eversberg at versatel.de
Wed Jun 15 12:10:19 UTC 2011


> Because you're using a C123 that doesn't require a 'MAGIC' marker when
> doing the code download.

netbook ~ # osmocom-roaming/src/host/osmocon/osmocon -p /dev/ttyUSB0 -m c140xor osmocom-roaming/src/target/firmware/board/compal_e88/layer1.compalram.bin
got 1 bytes from modem, data looks like: 00  .

does not seem so. but anyway: it is not a problem of the application "mobile". the process of one phone gets stuck while waiting for power measurement replay. the process of the other phone waits for the RACH confirm but never receives it. it looks pretty much like a broken layer1 or serial connection.

-----Ursprüngliche Nachricht-----
Von: Sylvain Munaut [mailto:246tnt at gmail.com] 
Gesendet: Mittwoch, 15. Juni 2011 13:31
An: Andreas.Eversberg
Cc: Basem Ahmed; baseband-devel at lists.osmocom.org
Betreff: Re: Facing issues in using OSMOCOM

On Wed, Jun 15, 2011 at 11:35 AM, Andreas.Eversberg
<Andreas.Eversberg at versatel.de> wrote:
> mine is >50k. why am i not getting the same warning?

Because you're using a C123 that doesn't require a 'MAGIC' marker when
doing the code download.

But when using the c140xor, osmocon will have to insert a specific
marker at a specific address for the bootloader to accept the file and
if the file is > 15 k, that marker will overwrite part of the binary
which will lead to something that can crash at any time (because
whatever code is overwritten will vary depending on a bunch of
factors)

   Sylvain




More information about the baseband-devel mailing list