Compile error with gpsd 2.96 in layer23

Konstantin Weitz konnew at gmx.de
Tue Jun 28 03:49:40 UTC 2011


Holger Hans Peter Freyther <holger <at> freyther.de> writes:

> 
> On 06/01/2011 04:32 PM, Malte Krupa wrote:
> > Dear folks,
> > 
> > I recently played with osmocomBB and wanted to try out the
> > cell_log and gsmmap feature.
> > Therefore I tried to rebuild osmocomBB (sylvains testing tree) with gpsd
> > 2.96 installed on archlinux kernel 2.6.38. 
> > 
> > If there is more information needed, just tell me!
> 
> well, you could try to
> 
> a) check the ChangeLog of GPSD if there was a change in the API.
> b) patch it.
> 
> holger
> 
> 

Apply this patch and it should work

Change $REPLACE$ to b/src/host/layer23/src/common/gps.c
before applying the patch






More information about the baseband-devel mailing list