running error with branch burst_ind

吴彤 cnwutong at gmail.com
Mon Apr 25 04:01:58 UTC 2011


Hi all,

Working with a C118 and everything was fine with the master branch, then
switched to the burst_ind branch and complied successfully, when running:

$  ./osmocon -p /dev/ttyUSB0 -m c123xor
../../target/firmware/board/compal_e88/layer1.compalram.bin
got 1 bytes from modem, data looks like: 2f  /
got 1 bytes from modem, data looks like: 00  .
got 5 bytes from modem, data looks like: 1b f6 02 00 41  ....A
got 1 bytes from modem, data looks like: 01  .
got 1 bytes from modem, data looks like: 40  @
Received PROMPT1 from phone, responding with CMD
read_file(../../target/firmware/board/compal_e88/layer1.compalram.bin):
file_size=48564, hdr_len=4, dnload_len=48571
got 1 bytes from modem, data looks like: 1b  .
got 1 bytes from modem, data looks like: f6  .
got 1 bytes from modem, data looks like: 02  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 41  A
got 1 bytes from modem, data looks like: 02  .
got 1 bytes from modem, data looks like: 43  C
Received PROMPT2 from phone, starting download
handle_write(): 4096 bytes (4096/48571)
handle_write(): 4096 bytes (8192/48571)
handle_write(): 4096 bytes (12288/48571)
handle_write(): 4096 bytes (16384/48571)
handle_write(): 4096 bytes (20480/48571)
handle_write(): 4096 bytes (24576/48571)
handle_write(): 4096 bytes (28672/48571)
handle_write(): 4096 bytes (32768/48571)
handle_write(): 4096 bytes (36864/48571)
handle_write(): 4096 bytes (40960/48571)
handle_write(): 4096 bytes (45056/48571)
handle_write(): 3515 bytes (48571/48571)
handle_write(): finished
got 1 bytes from modem, data looks like: 1b  .
got 1 bytes from modem, data looks like: f6  .
got 1 bytes from modem, data looks like: 02  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 41  A
got 1 bytes from modem, data looks like: 03  .
got 1 bytes from modem, data looks like: 42  B
Received DOWNLOAD ACK from phone, your code is running now!
ioctl(TIOCSSERIAL): Invalid argument

$ ./mobile
Copyright (C) 2008-2010 ...
Contributions by ...

License GPLv2+: GNU GPL version 2 or later <http://gnu.org/licenses/gpl.html
>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

VTY available on port 4247.
No Mobile Station defined, creating: MS '1'
<000e> sim.c:1206 init SIM client
<0005> gsm48_cc.c:61 init Call Control
<0001> gsm48_rr.c:4944 init Radio Ressource process
<0004> gsm48_mm.c:1220 init Mobility Management process
<0004> gsm48_mm.c:971 Selecting PLMN SEARCH state, because no SIM.
<0002> gsm322.c:3471 init PLMN process
<0003> gsm322.c:3472 init Cell Selection process
<0003> gsm322.c:3526 No stored BA list
Mobile '1' initialized, please start phone now!

then no reaction with the mobile application either rebooting the phone
(press power bottom) or not, for layer23 application acts the same.

tried to search for the message "ioctl(TIOCSSERIAL): Invalid argument" but
failed to get any useful information.

could anyone help and many thanks for your time and considerations!

best regards,

flaw
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/baseband-devel/attachments/20110425/bae62fea/attachment.html>


More information about the baseband-devel mailing list