libosmocom VERSION doesn't get set properly

jakob borg jakborg at fastmail.fm
Sun Oct 24 14:46:34 UTC 2010


hi,

when building libosmocom in osmocom-bb/src/shared (using the git-subtree
script to keep everything up to date), the Makefile in
src/shared/libosmocore/build-host doesn't have the version information
set properly, instead i get:

PACKAGE_VERSION = UNKNOWN
VERSION = UNKNOWN

this is causing problems compiling stuff that require libosmocom at a
specific version, like some of the airprobe tools.
i'm running mac os x 10.6.4, using autoconf 2.68, automake 1.11.1,
binutils 2.20.1, gcc 4.5.1.

when building the master git branch of libosmocom outside of osmocom-bb
(bootstrapping using the bootstrap script from airprobe/gsm-receiver),
the version gets set properly.

thanks

jakob

-- 
  jakob borg
  jakborg at fastmail.fm

-- 
http://www.fastmail.fm - One of many happy users:
  http://www.fastmail.fm/docs/quotes.html





More information about the baseband-devel mailing list