C139: get ftmtoolerror from ramloader

Harald Welte laforge at gnumonks.org
Thu Mar 18 00:27:07 UTC 2010


On Wed, Mar 17, 2010 at 10:33:41PM +0100, Erik Ekman wrote:
> Hi
> 
> I just got my cable and am trying to download any code into a C139
> (tracfone software, bought from usa on ebay).
> 
> This is what I get:
> $ ./osmocon -m c123 -p /dev/ttyS2 compal_dump.bin
> waiting for data
> got 7 bytes from modem, data looks like: 66 74 6d 74 6f 6f 6c
> Received FTMTOOL from phone, ramolader has aborted
> got 1 bytes from modem, data looks like: 65
> got 1 bytes from modem, data looks like: 72
> got 1 bytes from modem, data looks like: 72
> got 1 bytes from modem, data looks like: 6f
> got 1 bytes from modem, data looks like: 72
> ^C
> 
> From what I can tell the transfer mode and file doesn't matter at this
> stage. Any ideas?

not really. it might be the case that your software uses a different
bootloader or the port is configured differently.

> If I boot the phone and use 57600bps I get some prints and then AT
> returns OK, no other AT commands work.

I don't think the baud rate is the issue, as osmocon recognizes the
'ftmtool' from the phone, which is sent to the port _after_ the phone
has had a timeout waiting for osmocon (or other software) to download
some code into RAM.

-- 
- Harald Welte <laforge at gnumonks.org>           http://laforge.gnumonks.org/
============================================================================
"Privacy in residential applications is a desirable marketing option."
                                                  (ETSI EN 300 175-7 Ch. A6)




More information about the baseband-devel mailing list